Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Tracker miners and metadata extractors" |
| 2 | LICENSE = "GPLv2 & LGPLv2.1" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \ |
| 5 | file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 6 | " |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | intltool-native \ |
| 10 | tracker \ |
| 11 | zlib \ |
| 12 | " |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
| 16 | inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check |
| 17 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 18 | SRC_URI[archive.sha256sum] = "9509d37fb29acd233058f4df5bd1234b692ac6f946bc2e5f7b8dbf51dfe5b9fa" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | SRC_URI += "file://0001-meson.build-Just-warn-if-we-build-without-libseccomp.patch" |
| 20 | |
| 21 | # gobject-introspection is mandatory and cannot be configured |
| 22 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 23 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
| 24 | |
| 25 | PACKAGECONFIG ??= " \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 26 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "ffmpeg", "", d)} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | flac \ |
| 28 | gexiv2 \ |
| 29 | gstreamer \ |
| 30 | icu \ |
| 31 | libexif \ |
| 32 | libgsf \ |
| 33 | jpeg \ |
| 34 | png \ |
| 35 | tiff \ |
| 36 | xml \ |
| 37 | pdf \ |
| 38 | " |
| 39 | |
| 40 | PACKAGECONFIG[ffmpeg] = ",,ffmpeg" |
| 41 | PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac" |
| 42 | PACKAGECONFIG[gexiv2] = ",,gexiv2" |
| 43 | PACKAGECONFIG[gstreamer] = ",,gstreamer1.0 gstreamer1.0-plugins-base" |
| 44 | PACKAGECONFIG[gupnp] = ",,gupnp-dlna" |
| 45 | PACKAGECONFIG[icu] = ",,icu" |
| 46 | PACKAGECONFIG[libexif] = "-Dexif=enabled,-Dexif=disabled,libexif" |
| 47 | PACKAGECONFIG[libgsf] = "-Dgsf=enabled,-Dgsf=disabled,libgsf" |
| 48 | PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg" |
| 49 | PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng" |
| 50 | PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff" |
| 51 | PACKAGECONFIG[xml] = "-Dxml=enabled,-Dxml=disabled,libxml2" |
| 52 | PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis" |
| 53 | PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler" |
| 54 | PACKAGECONFIG[upower] = ",,upower" |
| 55 | |
| 56 | # For security reasons it is strongly recommended to set add meta-security in |
| 57 | # your layers and 'libseccomp' to PACKAGECONFIG". |
| 58 | PACKAGECONFIG[libseccomp] = ",,libseccomp" |
| 59 | # not yet in meta-gnome |
| 60 | PACKAGECONFIG[rss] = "-Dminer_rss=true,-Dminer_rss=false,libgrss" |
| 61 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 62 | EXTRA_OEMESON += " \ |
| 63 | -Dsystemd_user_services=${systemd_user_unitdir} \ |
| 64 | " |
| 65 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 66 | FILES_${PN} += " \ |
| 67 | ${datadir}/dbus-1 \ |
| 68 | ${datadir}/tracker \ |
| 69 | ${libdir}/tracker-miners-2.0 \ |
| 70 | ${systemd_user_unitdir} \ |
| 71 | " |