Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \ |
| 2 | TDD and BDD - using C++11, C++14, C++17 and later." |
| 3 | AUTHOR = "Phil Nash, Martin Horenovsky and others" |
| 4 | HOMEPAGE = "https://github.com/catchorg/Catch2" |
| 5 | LICENSE = "BSL-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 7 | |
| 8 | SRC_URI = "git://github.com/catchorg/Catch2.git \ |
| 9 | file://0001-Fix-convert-from-char-on-ARM-build.patch" |
| 10 | SRCREV = "9e1bdca4667295fcb16265eae00efa8423f07007" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit cmake python3native |
| 15 | |
| 16 | # Header-only library |
| 17 | RDEPENDS_${PN}-dev = "" |
| 18 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |
| 19 | |
| 20 | do_install_append() { |
| 21 | rm ${D}/${datadir}/Catch2/lldbinit |
| 22 | rm ${D}/${datadir}/Catch2/gdbinit |
| 23 | rmdir ${D}/${datadir}/Catch2/ |
| 24 | } |