Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit." |
| 2 | HOMEPAGE = "http://cxxtest.com/" |
| 3 | LICENSE = "LGPL-2.0" |
| 4 | SECTION = "devel" |
| 5 | |
| 6 | SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/cxxtest-${PV}.tar.gz" |
| 7 | SRC_URI[md5sum] = "b3a24b3e1aad9acf6adac37f4c3f83ec" |
| 8 | SRC_URI[sha256sum] = "356d0f4810e8eb5c344147a0cca50fc0d84122c286e7644b61cb365c2ee22083" |
| 9 | LIC_FILES_CHKSUM = "file://${WORKDIR}/cxxtest-${PV}/COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02" |
| 10 | S = "${WORKDIR}/cxxtest-${PV}/python" |
| 11 | |
| 12 | inherit distutils |
| 13 | |
| 14 | do_install_append() { |
| 15 | install -d ${D}${includedir} |
| 16 | cp -a ../cxxtest ${D}${includedir} |
| 17 | sed '1c\ |
| 18 | #!/usr/bin/env python' -i ${D}${bindir}/cxxtestgen |
| 19 | } |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |