Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Xfce4 Panel" |
| 2 | SECTION = "x11" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee" |
| 5 | DEPENDS = "libxfce4util garcon libxfce4ui xfconf exo gtk+ gtk+3 dbus cairo virtual/libx11 libxml2 libwnck3 vala-native" |
| 6 | |
| 7 | inherit xfce gtk-doc gobject-introspection distro_features_check gtk-icon-cache remove-libtool |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | SRC_URI[md5sum] = "0ccb448e3792949eb0ae9db8dc22789b" |
| 12 | SRC_URI[sha256sum] = "b467feb7ee9797ad12f56a152570e42a96b94ad63580d45536aabee282440ce8" |
| 13 | SRC_URI += " \ |
| 14 | file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \ |
| 15 | " |
| 16 | |
| 17 | python populate_packages_prepend() { |
| 18 | plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/') |
| 19 | plugin_name = d.expand('${PN}-plugin-%s') |
| 20 | do_split_packages(d, plugin_dir, '^lib(.*).so$', plugin_name, |
| 21 | '${PN} plugin for %s', extra_depends='', prepend=True, |
| 22 | aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop', |
| 23 | '${sysconfdir}/xdg/xfce/panel/%s-*', |
| 24 | '${datadir}/icons/hicolor/48x48/apps/*-%s.png', |
| 25 | '${bindir}/*%s*']) |
| 26 | } |
| 27 | |
| 28 | PACKAGES_DYNAMIC += "^${PN}-plugin-.*" |
| 29 | |
| 30 | PACKAGES =+ "${PN}-gtk3" |
| 31 | |
| 32 | FILES_${PN} += "${libdir}/xfce4/panel/migrate \ |
| 33 | ${libdir}/xfce4/panel/wrapper-1.0" |
| 34 | |
| 35 | FILES_${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la" |
| 36 | |
| 37 | FILES_${PN}-gtk3 = " \ |
| 38 | ${libdir}/libxfce4panel-2.0${SOLIBS} \ |
| 39 | ${libdir}/xfce4/panel/wrapper-2.0 \ |
| 40 | " |