Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Program for creating simple man pages" |
| 2 | SECTION = "devel" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | DEPENDS = "autoconf-native automake-native" |
| 6 | |
| 7 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz" |
| 8 | |
| 9 | SRC_URI[md5sum] = "7424901e6eca8af372d2ad62be5cf659" |
| 10 | SRC_URI[sha256sum] = "d91b0295b72a638e4a564f643e4e6d1928779131f628c00f356c13bf336de46f" |
| 11 | |
| 12 | inherit autotools native |
| 13 | |
| 14 | EXTRA_OECONF = "--disable-nls" |
| 15 | |
| 16 | # We don't want to reconfigure things as it would require 'perlnative' to be |
| 17 | # used. |
| 18 | do_configure() { |
| 19 | oe_runconf |
| 20 | } |
| 21 | |
| 22 | do_install_append () { |
| 23 | # Make sure we use /usr/bin/env perl |
| 24 | sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man |
| 25 | } |