Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=e021dd6dda6ff1e6b1044002fc662b9b \ |
| 8 | file://src/hb-ucdn/COPYING;md5=994ba0f1295f15b4bda4999a5bbeddef \ |
| 9 | " |
| 10 | |
| 11 | DEPENDS = "glib-2.0 cairo fontconfig freetype" |
| 12 | |
| 13 | SRC_URI = "http://www.freedesktop.org/software/harfbuzz/release/${BP}.tar.bz2" |
| 14 | SRC_URI[md5sum] = "81dbce82d6471ec2b2a627ce02d03e5d" |
| 15 | SRC_URI[sha256sum] = "a8e5c86e4d99e1cc9865ec1b8e9b05b98e413c2a885cd11f8e9bb9502dd3e3a9" |
| 16 | |
| 17 | inherit autotools pkgconfig lib_package gtk-doc |
| 18 | |
| 19 | PACKAGECONFIG ??= "icu" |
| 20 | PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu" |
| 21 | |
| 22 | EXTRA_OECONF = " \ |
| 23 | --with-cairo \ |
| 24 | --with-fontconfig \ |
| 25 | --with-freetype \ |
| 26 | --with-glib \ |
| 27 | --without-graphite2 \ |
| 28 | " |
| 29 | |
| 30 | do_configure_prepend() { |
| 31 | # This is ancient and can get used instead of the patched one we ship, |
| 32 | # so delete it. In 1.8.9 this should be removed upstream. |
| 33 | rm -f ${S}/m4/pkg.m4 |
| 34 | } |
| 35 | |
| 36 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev" |
| 37 | |
| 38 | LEAD_SONAME = "libharfbuzz.so" |
| 39 | |
| 40 | FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 41 | FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 42 | ${libdir}/libharfbuzz-icu.so \ |
| 43 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 44 | " |
| 45 | |
| 46 | BBCLASSEXTEND = "native" |