Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Extremely Fast Compression algorithm" |
| 2 | DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems." |
| 3 | |
| 4 | LICENSE = "BSD | BSD-2-Clause | GPL-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \ |
| 6 | file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 7 | file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \ |
| 8 | " |
| 9 | |
| 10 | PE = "1" |
| 11 | |
| 12 | SRCREV = "b3692db46d2b23a7c0af2d5e69988c94f126e10a" |
| 13 | |
| 14 | SRC_URI = "git://github.com/lz4/lz4.git \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}" |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake install |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |