Patrick Williams | 8b8bc41 | 2016-08-17 15:02:23 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Closed source binary files to help boot the ARM on the BCM2835." |
| 2 | LICENSE = "Proprietary" |
| 3 | |
| 4 | LIC_FILES_CHKSUM = "file://LICENCE.broadcom;md5=4a4d169737c0786fb9482bb6d30401d1" |
| 5 | |
| 6 | inherit deploy |
| 7 | |
| 8 | include recipes-bsp/common/firmware.inc |
| 9 | |
| 10 | RDEPENDS_${PN} = "rpi-config" |
| 11 | |
| 12 | COMPATIBLE_MACHINE = "raspberrypi" |
| 13 | |
| 14 | S = "${RPIFW_S}/boot" |
| 15 | |
| 16 | PR = "r3" |
| 17 | |
| 18 | do_deploy() { |
| 19 | install -d ${DEPLOYDIR}/${PN} |
| 20 | |
| 21 | for i in ${S}/*.elf ; do |
| 22 | cp $i ${DEPLOYDIR}/${PN} |
| 23 | done |
| 24 | for i in ${S}/*.dat ; do |
| 25 | cp $i ${DEPLOYDIR}/${PN} |
| 26 | done |
| 27 | for i in ${S}/*.bin ; do |
| 28 | cp $i ${DEPLOYDIR}/${PN} |
| 29 | done |
| 30 | |
| 31 | # Add stamp in deploy directory |
| 32 | touch ${DEPLOYDIR}/${PN}/${PN}-${PV}.stamp |
| 33 | } |
| 34 | |
| 35 | addtask deploy before do_package after do_install |
| 36 | do_deploy[dirs] += "${DEPLOYDIR}/${PN}" |
| 37 | |
| 38 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 39 | |