Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require python.inc |
| 2 | |
| 3 | EXTRANATIVEPATH += "bzip2-native" |
| 4 | DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native" |
| 5 | PR = "${INC_PR}.1" |
| 6 | |
| 7 | SRC_URI += "\ |
| 8 | file://05-enable-ctypes-cross-build.patch \ |
| 9 | file://10-distutils-fix-swig-parameter.patch \ |
| 10 | file://11-distutils-never-modify-shebang-line.patch \ |
| 11 | file://12-distutils-prefix-is-inside-staging-area.patch \ |
| 12 | file://debug.patch \ |
| 13 | file://unixccompiler.patch \ |
| 14 | file://nohostlibs.patch \ |
| 15 | file://multilib.patch \ |
| 16 | file://add-md5module-support.patch \ |
| 17 | file://builddir.patch \ |
| 18 | file://parallel-makeinst-create-bindir.patch \ |
| 19 | file://revert_use_of_sysconfigdata.patch \ |
| 20 | file://avoid_parallel_make_races_on_pgen.patch \ |
| 21 | " |
| 22 | S = "${WORKDIR}/Python-${PV}" |
| 23 | |
| 24 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:" |
| 25 | |
| 26 | inherit native |
| 27 | |
| 28 | RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native" |
| 29 | |
| 30 | EXTRA_OECONF_append = " --bindir=${bindir}/${PN}" |
| 31 | |
| 32 | EXTRA_OEMAKE = '\ |
| 33 | BUILD_SYS="" \ |
| 34 | HOST_SYS="" \ |
| 35 | LIBC="" \ |
| 36 | STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \ |
| 37 | STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \ |
| 38 | ' |
| 39 | |
| 40 | do_configure_append() { |
| 41 | autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi |
| 42 | } |
| 43 | |
| 44 | do_install() { |
| 45 | oe_runmake 'DESTDIR=${D}' install |
| 46 | install -d ${D}${bindir}/${PN} |
| 47 | install -m 0755 Parser/pgen ${D}${bindir}/${PN} |
| 48 | |
| 49 | # Make sure we use /usr/bin/env python |
| 50 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do |
| 51 | sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT |
| 52 | done |
| 53 | |
| 54 | # Add a symlink to the native Python so that scripts can just invoke |
| 55 | # "nativepython" and get the right one without needing absolute paths |
| 56 | # (these often end up too long for the #! parser in the kernel as the |
| 57 | # buffer is 128 bytes long). |
| 58 | ln -s python-native/python ${D}${bindir}/nativepython |
| 59 | |
| 60 | # We don't want modules in ~/.local being used in preference to those |
| 61 | # installed in the native sysroot, so disable user site support. |
| 62 | sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py |
| 63 | } |