Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Support for reading various archive formats" |
| 2 | DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats" |
| 3 | HOMEPAGE = "http://www.libarchive.org/" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b4e3ffd607d6686c6cb2f63394370841" |
| 7 | |
| 8 | DEPENDS = "e2fsprogs-native" |
| 9 | |
| 10 | PACKAGECONFIG ?= "libxml2 zlib bz2" |
| 11 | |
| 12 | PACKAGECONFIG_append_class-target = "\ |
| 13 | ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \ |
| 14 | ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \ |
| 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \ |
| 16 | " |
| 17 | |
| 18 | PACKAGECONFIG_append_class-nativesdk = " largefile" |
| 19 | |
| 20 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," |
| 21 | PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," |
| 22 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," |
| 23 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," |
| 24 | PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,bzip2," |
| 25 | PACKAGECONFIG[xz] = "--with-lzmadec --with-lzma,--without-lzmadec --without-lzma,xz," |
| 26 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," |
| 27 | PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2," |
| 28 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat," |
| 29 | PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo," |
| 30 | PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle," |
| 31 | |
| 32 | SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \ |
| 33 | file://libarchive-CVE-2013-0211.patch \ |
| 34 | file://pkgconfig.patch \ |
| 35 | file://0001-Add-ARCHIVE_EXTRACT_SECURE_NOABSOLUTEPATHS-option.patch \ |
| 36 | file://mkdir.patch \ |
| 37 | " |
| 38 | |
| 39 | SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a" |
| 40 | SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e" |
| 41 | |
| 42 | inherit autotools lib_package pkgconfig |
| 43 | |
| 44 | CPPFLAGS += "-I${WORKDIR}/extra-includes" |
| 45 | |
| 46 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" |
| 47 | do_configure_prepend() { |
| 48 | # We just need the headers for some type constants, so no need to |
| 49 | # build all of e2fsprogs for the target |
| 50 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ |
| 51 | } |
| 52 | |
| 53 | BBCLASSEXTEND = "native nativesdk" |