Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | DESCRIPTION = "A generic patricia trie (also called radix tree) implemented in Go (Golang)" |
| 2 | HOMEPAGE = "https://github.com/gorilla/context" |
| 3 | SECTION = "devel/go" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9949b99212edd6b1e24ce702376c3baf" |
| 6 | |
| 7 | SRCNAME = "go-patricia" |
| 8 | |
| 9 | PKG_NAME = "github.com/tchap/${SRCNAME}" |
| 10 | SRC_URI = "git://${PKG_NAME}.git" |
| 11 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | SRCREV = "666120de432aea38ab06bd5c818f04f4129882c9" |
| 13 | PV = "2.2.6+git${SRCPV}" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${prefix}/local/go/src/${PKG_NAME} |
| 19 | cp -r ${S}/* ${D}${prefix}/local/go/src/${PKG_NAME}/ |
| 20 | } |
| 21 | |
| 22 | SYSROOT_PREPROCESS_FUNCS += "go_patricia_sysroot_preprocess" |
| 23 | |
| 24 | go_patricia_sysroot_preprocess () { |
| 25 | install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME} |
| 26 | cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME}) |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*" |