Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "General purpose cryptographic library based on the code from GnuPG" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A cryptography library developed as a separated module of GnuPG. \ |
| 3 | It can also be used independently of GnuPG, but depends on its error-reporting \ |
| 4 | library Libgpg-error." |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/" |
| 6 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 7 | SECTION = "libs" |
| 8 | |
| 9 | # helper program gcryptrnd and getrandom are under GPL, rest LGPL |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 10 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | LICENSE:${PN} = "LGPL-2.1-or-later" |
| 12 | LICENSE:${PN}-dev = "GPL-2.0-or-later & LGPL-2.1-or-later" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 15 | file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 16 | file://LICENSES;md5=ef545b6cc717747072616519a1256d69 \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 17 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | DEPENDS = "libgpg-error" |
| 20 | |
| 21 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 22 | SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 23 | file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \ |
| 25 | file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \ |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 26 | file://no-native-gpg-error.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 27 | file://no-bench-slope.patch \ |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 28 | file://run-ptest \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 29 | " |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 30 | SRC_URI[sha256sum] = "ef14ae546b0084cd84259f61a55e07a38c3b53afc0f546bffcef2f01baffe9de" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 32 | # Below whitelisted CVEs are disputed and not affecting crypto libraries for any distro. |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 33 | CVE_CHECK_IGNORE += "CVE-2018-12433 CVE-2018-12438" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 34 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 35 | BINCONFIG = "${bindir}/libgcrypt-config" |
| 36 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 37 | inherit autotools texinfo binconfig-disabled pkgconfig ptest |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | |
| 39 | EXTRA_OECONF = "--disable-asm" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 41 | |
| 42 | PACKAGECONFIG ??= "capabilities" |
| 43 | PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap" |
| 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | do_configure:prepend () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 46 | # Else this could be used in preference to the one in aclocal-copy |
| 47 | rm -f ${S}/m4/gpg-error.m4 |
| 48 | } |
| 49 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 50 | do_install_ptest() { |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 51 | cd tests |
| 52 | oe_runmake testdrv-build testdrv |
| 53 | install testdrv $(srcdir=${S}/tests ./testdrv-build --files | sort | uniq) ${D}${PTEST_PATH} |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 54 | } |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 55 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 56 | FILES:${PN}-dev += "${bindir}/hmac256 ${bindir}/dumpsexp" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | |
| 58 | BBCLASSEXTEND = "native nativesdk" |