Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Javascript bindings for GNOME" |
| 2 | LICENSE = "MIT & LGPLv2+" |
| 3 | LIC_FILES_CHKSUM = " \ |
| 4 | file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \ |
| 5 | file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \ |
| 6 | " |
| 7 | |
| 8 | GNOMEBASEBUILDCLASS = "autotools" |
| 9 | |
| 10 | DEPENDS = "mozjs gtk+3" |
| 11 | |
| 12 | inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even |
| 13 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 14 | SRC_URI[archive.sha256sum] = "7fb3eb746c17363d9ee47f4a5d0bb048f0075611763eb0da11d85e0e57aff381" |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 15 | SRC_URI += "file://0001-Disable-tests-on-host.patch \ |
| 16 | file://0001-maint-Avoid-g_once_init_enter-error-in-GCC-11.patch \ |
| 17 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | # gobject-introspection is mandatory and cannot be configured |
| 20 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | UNKNOWN_CONFIGURE_WHITELIST:append = " --enable-introspection --disable-introspection" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | EXTRA_OECONF = " \ |
| 24 | --without-dbus-tests \ |
| 25 | --disable-installed-tests \ |
| 26 | " |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | do_configure:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | # make configure find gobject-introspection test code. Although we set |
| 30 | # --disable-installed-tests gjs builds them |
| 31 | sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac |
| 32 | } |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN} += "${datadir}/gjs-1.0/lsan" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | |
| 36 | PACKAGES =+ "${PN}-valgrind" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:${PN}-valgrind = "${datadir}/gjs-1.0/valgrind" |
William A. Kennington III | 49e9566 | 2021-09-15 16:19:36 -0700 | [diff] [blame] | 38 | RDEPENDS:${PN}-valgrind += "valgrind" |
| 39 | |
| 40 | # Valgrind not yet available on rv32/rv64 |
| 41 | RDEPENDS:${PN}-valgrind:remove:riscv32 = "valgrind" |
| 42 | RDEPENDS:${PN}-valgrind:remove:riscv64 = "valgrind" |