Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "H.264/MPEG-4 AVC video encoder" |
| 2 | DESCRIPTION = "A free software library and application for encoding video streams into the H.264/MPEG-4 AVC format." |
| 3 | HOMEPAGE = "http://www.videolan.org/developers/x264.html" |
| 4 | |
| 5 | LICENSE = "GPLv2" |
| 6 | LICENSE_FLAGS = "commercial" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 8 | |
| 9 | DEPENDS = "yasm-native" |
| 10 | |
| 11 | SRC_URI = "git://git.videolan.org/x264.git \ |
| 12 | file://don-t-default-to-cortex-a9-with-neon.patch \ |
| 13 | " |
| 14 | |
| 15 | SRCREV = "c8a773ebfca148ef04f5a60d42cbd7336af0baf6" |
| 16 | |
| 17 | PV = "r2491+git${SRCPV}" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit lib_package pkgconfig perlnative |
| 22 | |
| 23 | X264_DISABLE_ASM = "" |
| 24 | X264_DISABLE_ASM_armv4 = "--disable-asm" |
| 25 | X264_DISABLE_ASM_armv5 = "--disable-asm" |
| 26 | X264_DISABLE_ASM_powerpc = "${@bb.utils.contains("TUNE_FEATURES", "spe", "--disable-asm", "", d)}" |
| 27 | |
| 28 | EXTRA_OECONF = '--prefix=${prefix} \ |
| 29 | --host=${HOST_SYS} \ |
| 30 | --libdir=${libdir} \ |
| 31 | --cross-prefix=${TARGET_PREFIX} \ |
| 32 | --sysroot=${STAGING_DIR_TARGET} \ |
| 33 | --enable-shared \ |
| 34 | --enable-static \ |
| 35 | --disable-lavf \ |
| 36 | --disable-swscale \ |
| 37 | --enable-pic \ |
| 38 | ${X264_DISABLE_ASM} \ |
| 39 | ' |
| 40 | |
| 41 | do_configure() { |
| 42 | ./configure ${EXTRA_OECONF} |
| 43 | } |
| 44 | |
| 45 | # Get rid of -e |
| 46 | EXTRA_OEMAKE = "" |
| 47 | AS = "${TARGET_PREFIX}gcc" |
| 48 | |
| 49 | do_install() { |
| 50 | oe_runmake install DESTDIR=${D} |
| 51 | } |
| 52 | |
| 53 | # PIC can't be enabled for 32-bit x86 |
| 54 | INSANE_SKIP_${PN}_append_x86 = " textrel" |
| 55 | |