Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Creative photo display application" |
| 2 | DESCRIPTION = "Fotowall is a creative tool that allows you to layout your photos or pictures \ |
| 3 | in a personal way. You can add pictures, then resize, move, change colors, text, shadows, etc.." |
| 4 | |
| 5 | HOMEPAGE = "http://www.enricoros.com/opensource/fotowall" |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://GPL_V2;md5=79808397c3355f163c012616125c9e26 \ |
| 8 | file://main.cpp;beginline=6;endline=11;md5=b569acc2bf8974a3082b58fc53b9d8dc" |
| 9 | SECTION = "x11/apps" |
| 10 | |
| 11 | PR = "r4" |
| 12 | |
| 13 | SRCREV = "06d5a4142c599604d9a9fd64727b6945eb8cd3da" |
| 14 | SRC_URI = "git://github.com/enricoros/fotowall.git \ |
| 15 | file://ExportWizard-depends-on-ui_wizard.patch \ |
| 16 | " |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit qt4x11 |
| 21 | |
| 22 | EXTRA_QMAKEVARS_PRE = "CONFIG+=no-webcam" |
| 23 | |
| 24 | do_install() { |
| 25 | oe_runmake INSTALL_ROOT=${D} install |
| 26 | } |
| 27 | |
| 28 | # Ensure we have some plugins for some useful image formats |
| 29 | RRECOMMENDS_${PN} += "qt4-plugin-imageformat-gif qt4-plugin-imageformat-jpeg qt4-plugin-imageformat-tiff" |