Brian Yang | 627b366 | 2018-07-28 04:01:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Lanyang IPMI to DBus Inventory mapping." |
| 2 | PR = "r1" |
Brad Bishop | 86e8260 | 2018-11-06 09:36:08 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | 7ec1d67 | 2019-09-13 14:04:55 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Brian Yang | 627b366 | 2018-07-28 04:01:57 -0400 | [diff] [blame] | 5 | |
| 6 | inherit native |
Brian Yang | 627b366 | 2018-07-28 04:01:57 -0400 | [diff] [blame] | 7 | inherit phosphor-ipmi-fru |
| 8 | |
| 9 | SRC_URI += "file://config.yaml" |
| 10 | |
| 11 | PROVIDES += "virtual/phosphor-ipmi-fru-inventory" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install() { |
| 16 | # TODO: install this to inventory_datadir |
| 17 | # after ipmi-fru-parser untangles the host |
| 18 | # firmware config from the machine inventory. |
| 19 | DEST=${D}${config_datadir} |
| 20 | |
| 21 | install -d ${DEST} |
| 22 | install config.yaml ${DEST} |
| 23 | } |
| 24 | |