Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome/libs" |
| 5 | LICENSE = "LGPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl" |
| 9 | |
| 10 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 11 | |
| 12 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
| 13 | SRC_URI[md5sum] = "603f3a945cd6ecc1fda644d7853b3b81" |
| 14 | SRC_URI[sha256sum] = "2d50b12922cc516ab6a7c35844d42f9c8a331668bbdf139232743d82582b3294" |
| 15 | |
| 16 | CVE_PRODUCT = "libsoup" |
| 17 | |
| 18 | S = "${WORKDIR}/libsoup-${PV}" |
| 19 | |
| 20 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 21 | |
| 22 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 23 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 24 | |
| 25 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 26 | PACKAGECONFIG ??= "" |
| 27 | PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| 28 | PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5" |
| 29 | |
| 30 | EXTRA_OEMESON_append = " -Dvapi=disabled -Dtls_check=false" |
| 31 | |
| 32 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 33 | |
| 34 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 35 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 36 | # renaming in order to keep the package name consistent regardless of whether |
| 37 | # gnome support is enabled or disabled. |
| 38 | DEBIAN_NOAUTONAME_${PN} = "1" |
| 39 | |
| 40 | # glib-networking is needed for SSL, proxies, etc. |
| 41 | RRECOMMENDS_${PN} = "glib-networking" |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |