Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux libcamera framework" |
| 2 | SECTION = "libs" |
| 3 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame^] | 4 | LICENSE = "GPL-2.0+ & LGPL-2.1+" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 5 | |
| 6 | LIC_FILES_CHKSUM = "\ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 7 | file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \ |
| 8 | file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | " |
| 10 | |
| 11 | SRC_URI = " \ |
| 12 | git://linuxtv.org/libcamera.git;protocol=git \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 13 | " |
| 14 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 15 | SRCREV = "5f2f9406cebc668f0d69007d1ea59ef3c56ef28c" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 17 | PV = "202006+git${SRCPV}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame^] | 21 | DEPENDS = "python3-pyyaml-native udev gnutls boost chrpath-native" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 22 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}" |
| 23 | |
| 24 | RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}" |
| 25 | |
| 26 | inherit meson pkgconfig python3native |
| 27 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame^] | 28 | do_install_append() { |
| 29 | chrpath -d ${D}${libdir}/libcamera.so |
| 30 | } |
| 31 | |
| 32 | addtask do_recalculate_ipa_signatures_package after do_package before do_packagedata |
| 33 | do_recalculate_ipa_signatures_package() { |
| 34 | local modules |
| 35 | for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do |
| 36 | module="${module%.sign}" |
| 37 | if [ -f "${module}" ] ; then |
| 38 | modules="${modules} ${module}" |
| 39 | fi |
| 40 | done |
| 41 | |
| 42 | ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}" |
| 43 | } |
| 44 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 45 | FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig" |
| 46 | FILES_${PN} += " ${libdir}/libcamera.so" |
| 47 | |