Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Fast Log processor and Forwarder" |
| 2 | DESCRIPTION = "Fluent Bit is a data collector, processor and \ |
| 3 | forwarder for Linux. It supports several input sources and \ |
| 4 | backends (destinations) for your data. \ |
| 5 | " |
| 6 | |
| 7 | HOMEPAGE = "http://fluentbit.io" |
| 8 | BUGTRACKER = "https://github.com/fluent/fluent-bit/issues" |
| 9 | |
| 10 | LICENSE = "Apache-2.0" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93" |
| 12 | SECTION = "net" |
| 13 | |
| 14 | SRC_URI = "http://fluentbit.io/releases/1.3/fluent-bit-${PV}.tar.gz \ |
| 15 | file://jemalloc.patch \ |
| 16 | file://cross-build-init-system-detection.patch \ |
| 17 | file://builtin-nan.patch \ |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 18 | file://0001-ppc-Fix-signature-for-co_create-API.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 19 | " |
| 20 | SRC_URI[md5sum] = "6eae6dfd0a874e5dd270c36e9c68f747" |
| 21 | SRC_URI[sha256sum] = "e037c76c89269c8dc4027a08e442fefd2751b0f1e0f9c38f9a4b12d781a9c789" |
| 22 | |
| 23 | S = "${WORKDIR}/fluent-bit-${PV}" |
| 24 | DEPENDS = "zlib bison-native flex-native" |
| 25 | DEPENDS_append_libc-musl = " fts " |
| 26 | |
| 27 | INSANE_SKIP_${PN}-dev += "dev-elf" |
| 28 | |
| 29 | # Use CMake 'Unix Makefiles' generator |
| 30 | OECMAKE_GENERATOR ?= "Unix Makefiles" |
| 31 | |
| 32 | # Fluent Bit build options |
| 33 | # ======================== |
| 34 | |
| 35 | # Host related setup |
| 36 | EXTRA_OECMAKE += "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1" |
| 37 | |
| 38 | # Disable LuaJIT and filter_lua support |
| 39 | EXTRA_OECMAKE += "-DFLB_LUAJIT=Off -DFLB_FILTER_LUA=Off " |
| 40 | |
| 41 | # Disable Library and examples |
| 42 | EXTRA_OECMAKE += "-DFLB_SHARED_LIB=Off -DFLB_EXAMPLES=Off " |
| 43 | |
| 44 | EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES','systemd','-DFLB_SYSTEMD=On','',d)}" |
| 45 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 46 | EXTRA_OECMAKE_append_riscv64 = " -DFLB_DEPS='atomic'" |
| 47 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 48 | # Kafka Output plugin (disabled by default): note that when |
| 49 | # enabling Kafka output plugin, the backend library librdkafka |
| 50 | # requires 'openssl' as a dependency. |
| 51 | # |
| 52 | # DEPENDS += "openssl " |
| 53 | # EXTRA_OECMAKE += "-DFLB_OUT_KAFKA=On " |
| 54 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 55 | inherit cmake systemd |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 56 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame^] | 57 | CFLAGS += "-fcommon" |
| 58 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 59 | SYSTEMD_SERVICE_${PN} = "td-agent-bit.service" |
| 60 | TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}" |