blob: 806e67c09171d26c1217784ad17b6d2b440924ee [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Library for building powerful interactive command lines in Python"
2HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
5
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05006SRC_URI[md5sum] = "e50cb328715b338480d8d29dda54ff5d"
7SRC_URI[sha256sum] = "7630ab85a23302839a0f26b31cc24f518e6155dea1ed395ea61b42c45941b6a6"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008
9inherit pypi setuptools3
10
11PYPI_PACKAGE = "prompt_toolkit"
12
13RDEPENDS_${PN} += " \
14 ${PYTHON_PN}-core \
15 ${PYTHON_PN}-six \
16 ${PYTHON_PN}-terminal \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-wcwidth \
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-shell \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021 ${PYTHON_PN}-image \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050022"
23
24BBCLASSEXTEND = "native nativesdk"