blob: 9c9c327b7ef5b473be9479ac6a542a19af3c145c [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Xfce screensaver Application"
2DESCRIPTION = "Xfce screensaver is a screen saver and locker that aims to have simple, sane, secure defaults and be well integrated with the desktop."
3HOMEPAGE = "https://git.xfce.org/apps/xfce4-screensaver/about/"
4SECTION = "x11/application"
5
6LICENSE = "GPLv2+ & LGPLv2+ "
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://COPYING.LGPL;md5=4fbd65380cdd255951079008b364516c \
9 "
10
Brad Bishop2f973922019-11-11 07:58:48 -050011DEPENDS = "dbus-glib garcon gtk+3 libxklavier libxscrnsaver virtual/libx11 xfconf libwnck3"
Brad Bishop15ae2502019-06-18 21:44:24 -040012
13inherit xfce-app
14
Brad Bishopc8f47122019-06-24 09:36:18 -040015SRC_URI_append = " \
16 file://fix-cross-compile.patch \
17 file://fix-pam-config.patch \
18"
Brad Bishop2f973922019-11-11 07:58:48 -050019SRC_URI[md5sum] = "0fea7b676e6e533a3f305c6f642fe0cd"
20SRC_URI[sha256sum] = "4056045ea5fd3eccfe328b86ae245ee4949b9e3044e42ca29c492c0f4ac860d7"
Brad Bishopc8f47122019-06-24 09:36:18 -040021
22do_install_append() {
23 install -D -m 0644 ${S}/data/xfce4-screensaver.common-auth ${D}${sysconfdir}/pam.d/xfce4-screensaver
24}
Brad Bishop15ae2502019-06-18 21:44:24 -040025
26FILES_${PN} += "${datadir}/dbus-1 ${datadir}/desktop-directories"
Brad Bishop2f973922019-11-11 07:58:48 -050027RDEPENDS_${PN} += "python3-core"