Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "eeePC specific ACPI scripts" |
| 2 | HOMEPAGE = "http://alioth.debian.org/projects/debian-eeepc/" |
| 3 | SECTION = "base" |
| 4 | |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://debian/copyright;md5=77ef83ab5f4af938a93edb61f7b74f2c" |
| 7 | |
| 8 | SRCREV = "9d4cdedca25b396405f8587f9c4fbf8229e041c2" |
| 9 | PV = "1.1.12+git${SRCPV}" |
| 10 | |
| 11 | SRC_URI = "git://git.debian.org/git/debian-eeepc/eeepc-acpi-scripts.git \ |
| 12 | file://remove-doc-check.patch \ |
| 13 | file://powerbtn.patch \ |
| 14 | file://policy-funcs " |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | FILES_${PN} = "${datadir}/acpi-support/ \ |
| 19 | ${datadir}/eeepc-acpi-scripts \ |
| 20 | ${sysconfdir}/default/ \ |
| 21 | ${sysconfdir}/acpi/" |
| 22 | |
| 23 | do_install () { |
| 24 | install -d ${D}${sysconfdir}/default/ |
| 25 | install -d ${D}${sysconfdir}/acpi/actions/ |
| 26 | install -d ${D}${sysconfdir}/acpi/events/ |
| 27 | install -d ${D}${sysconfdir}/acpi/lib/udev/rules.d |
| 28 | install -d ${D}${datadir}/eeepc-acpi-scripts/ |
| 29 | install -d ${D}${datadir}/acpi-support/ |
| 30 | install -m 644 ${S}/events/* ${D}${sysconfdir}/acpi/events/ |
| 31 | install -m 644 ${S}/lib/udev/rules.d/* ${D}${sysconfdir}/acpi/lib/udev/rules.d/ |
| 32 | install ${S}/actions/* ${D}${sysconfdir}/acpi/actions/ |
| 33 | install -m 0644 ${S}/acpilib/functions.sh ${D}${datadir}/eeepc-acpi-scripts/ |
| 34 | install -m 0644 ${WORKDIR}/policy-funcs ${D}${datadir}/acpi-support/ |
| 35 | install -m 0644 ${S}/debian/eeepc-acpi-scripts.default* ${D}${sysconfdir}/default/ |
| 36 | } |
| 37 | |
| 38 | RDEPENDS_${PN} = "pm-utils" |
| 39 | |