Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Enables PPP dial-in through a serial connection" |
| 2 | SECTION = "console/network" |
| 3 | DEPENDS = "ppp" |
| 4 | RDEPENDS_${PN} = "ppp" |
| 5 | PR = "r8" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \ |
| 8 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 9 | |
| 10 | SRC_URI = "file://host-peer \ |
| 11 | file://ppp-dialin" |
| 12 | |
| 13 | inherit allarch useradd |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}${sysconfdir}/ppp/peers |
| 19 | install -m 0644 ${WORKDIR}/host-peer ${D}${sysconfdir}/ppp/peers/host |
| 20 | |
| 21 | install -d ${D}${sbindir} |
| 22 | install -m 0755 ${WORKDIR}/ppp-dialin ${D}${sbindir} |
| 23 | } |
| 24 | |
| 25 | USERADD_PACKAGES = "${PN}" |
| 26 | USERADD_PARAM_${PN} = "--system --home /dev/null \ |
| 27 | --no-create-home --shell ${sbindir}/ppp-dialin \ |
| 28 | --no-user-group --gid nogroup ppp" |