Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | # Copyright (C) 2012 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Linux kernel style configuration framework for other projects" |
| 5 | DESCRIPTION = "The kconfig-frontends project aims at centralising \ |
| 6 | the effort of keeping an up-to-date, out-of-tree, packaging of the \ |
| 7 | kconfig infrastructure, ready for use by third-party projects. \ |
| 8 | The kconfig-frontends package provides the kconfig parser, as well as all \ |
| 9 | the frontends" |
| 10 | HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends" |
| 11 | LICENSE = "GPL-2.0" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408" |
| 13 | SECTION = "devel" |
| 14 | DEPENDS += "ncurses flex bison gperf-native pkgconfig-native" |
| 15 | RDEPENDS_${PN} += "python bash" |
| 16 | SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BP}.tar.xz" |
| 17 | |
| 18 | SRC_URI[md5sum] = "b939280dcc83f8feabd87a1d5f9b00c2" |
| 19 | SRC_URI[sha256sum] = "ea2615a62c74bea6ce3b38402f00c7513858f307f6ba7aa9fdbf0bbc12bcf407" |
| 20 | |
| 21 | inherit autotools |
| 22 | do_configure_prepend () { |
| 23 | mkdir -p scripts/.autostuff/m4 |
| 24 | } |
| 25 | |
| 26 | do_install_append() { |
| 27 | ln -s kconfig-conf ${D}${bindir}/conf |
| 28 | ln -s kconfig-mconf ${D}${bindir}/mconf |
| 29 | } |
| 30 | |
| 31 | EXTRA_OECONF += "--disable-gconf --disable-qconf" |
| 32 | |
| 33 | # Some packages have the version preceeding the .so instead properly |
| 34 | # versioned .so.<version>, so we need to reorder and repackage. |
| 35 | SOLIBS = "-${@d.getVar('PV',1)[:-2]}.so" |
| 36 | FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so" |
| 37 | |
| 38 | BBCLASSEXTEND = "native" |