Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "The RPM package management system" |
| 2 | DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \ |
| 3 | package management system capable of installing, uninstalling, \ |
| 4 | verifying, querying, and updating software packages. Each software \ |
| 5 | package consists of an archive of files along with information about \ |
| 6 | the package like its version, a description, etc." |
| 7 | |
| 8 | SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages" |
| 9 | DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries." |
| 10 | |
| 11 | SUMMARY_${PN}-dev = "Development files for manipulating RPM packages" |
| 12 | DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \ |
| 13 | development files will simplify the process of writing programs that \ |
| 14 | manipulate RPM packages and databases. These files are intended to \ |
| 15 | simplify the process of creating graphical package managers or any \ |
| 16 | other tools that need an intimate knowledge of RPM packages in order \ |
| 17 | to function." |
| 18 | |
| 19 | SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration" |
| 20 | DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \ |
| 21 | and configuration common between RPM Package Manager." |
| 22 | |
| 23 | SUMMARY_${PN}-build = "Scripts and executable programs used to build packages" |
| 24 | DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \ |
| 25 | that are used to build packages using the RPM Package Manager." |
| 26 | |
| 27 | SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages" |
| 28 | DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \ |
| 29 | written in the Python programming language to use the interface \ |
| 30 | supplied by the RPM Package Manager libraries." |
| 31 | |
| 32 | SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages" |
| 33 | DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \ |
| 34 | written in the Perl programming language to use the interface \ |
| 35 | supplied by the RPM Package Manager libraries." |
| 36 | |
| 37 | SUMMARY_perl-module-rpm-dev = "Development components for perl bindings" |
| 38 | DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \ |
| 39 | language bindings." |
| 40 | |
| 41 | HOMEPAGE = "http://rpm5.org/" |
| 42 | LICENSE = "LGPLv2.1" |
| 43 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 44 | |
| 45 | DEPENDS = "libpcre attr acl popt ossp-uuid file byacc-native" |
| 46 | |
| 47 | S = "${WORKDIR}/rpm" |
| 48 | |
| 49 | # Apply various fixups that are unique to the CVS environment |
| 50 | do_fixup_unpack () { |
| 51 | ln -sf ../syck ${S}/syck || : |
| 52 | ln -sf ../lua ${S}/lua || : |
| 53 | ln ${S}/rpmqv.c ${S}/rpmqv.cc || : |
| 54 | } |
| 55 | |
| 56 | addtask fixup_unpack after do_unpack before do_patch |
| 57 | |
| 58 | # This recipe is really designed for development... to Try out the latest |
| 59 | # community work in progress. |
| 60 | DEFAULT_PREFERENCE = "-1" |
| 61 | |
| 62 | # rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed |
| 63 | # in order to extract the distribution SRPM into a format we can extract... |
| 64 | SRC_URI = "cvs://anonymous@rpm5.org/cvs;tag=rpm-5_4;module=rpm \ |
| 65 | cvs://anonymous@rpm5.org/cvs;tag=rpm-5_4;module=syck \ |
| 66 | cvs://anonymous@rpm5.org/cvs;tag=rpm-5_4;module=lua \ |
| 67 | file://rpm-log-auto-rm.patch \ |
| 68 | file://rpm-db-reduce.patch \ |
| 69 | file://perfile_rpmdeps.sh \ |
| 70 | file://rpm-autogen.patch \ |
| 71 | file://rpm-libsql-fix.patch \ |
| 72 | file://header-include-fix.patch \ |
| 73 | file://rpm-platform.patch \ |
| 74 | file://rpm-showrc.patch \ |
| 75 | file://rpm-tools-mtree-LDFLAGS.patch \ |
| 76 | file://rpm-fileclass.patch \ |
| 77 | file://rpm-canonarch.patch \ |
| 78 | file://rpm-no-loopmsg.patch \ |
| 79 | file://rpm-scriptletexechelper.patch \ |
| 80 | file://pythondeps.sh \ |
| 81 | file://rpmdeps-oecore.patch \ |
| 82 | file://rpm-resolvedep.patch \ |
| 83 | file://rpm-no-perl-urpm.patch \ |
| 84 | file://rpm-macros.patch \ |
| 85 | file://rpm-lua.patch \ |
| 86 | file://rpm-ossp-uuid.patch \ |
| 87 | file://rpm-packageorigin.patch \ |
| 88 | file://rpm-pkgconfigdeps.patch \ |
| 89 | file://uclibc-support.patch \ |
| 90 | file://rpmatch.patch \ |
| 91 | file://fstack-protector-configure-check.patch \ |
| 92 | file://dbconvert.patch \ |
| 93 | file://rpm-uuid-include.patch \ |
| 94 | file://makefile-am-exec-hook.patch \ |
| 95 | file://rpm-db_buffer_small.patch \ |
| 96 | file://rpm-py-init.patch \ |
| 97 | file://python-rpm-rpmsense.patch \ |
| 98 | file://rpm-reloc-macros.patch \ |
| 99 | file://rpm-platform2.patch \ |
| 100 | file://rpm-remove-sykcparse-decl.patch \ |
| 101 | file://debugedit-segv.patch \ |
| 102 | file://debugedit-valid-file-to-fix-segment-fault.patch \ |
| 103 | file://rpm-platform-file-fix.patch \ |
| 104 | file://rpm-lsb-compatibility.patch \ |
| 105 | file://rpm-tag-generate-endian-conversion-fix.patch \ |
| 106 | file://rpm-hardlink-segfault-fix.patch \ |
| 107 | file://rpm-payload-use-hashed-inode.patch \ |
| 108 | file://rpm-fix-logio-cp.patch \ |
| 109 | file://rpm-db5-or-db6.patch \ |
| 110 | file://rpm-rpmpgp-fix.patch \ |
| 111 | file://rpm-disable-Wno-override-init.patch \ |
| 112 | file://rpm-realpath.patch \ |
| 113 | " |
| 114 | |
| 115 | # Uncomment the following line to enable platform score debugging |
| 116 | # This is useful when identifying issues with Smart being unable |
| 117 | # to process certain package feeds. |
| 118 | #SRC_URI += "file://rpm-debug-platform.patch" |
| 119 | |
| 120 | inherit autotools gettext |
| 121 | |
| 122 | acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java" |
| 123 | |
| 124 | # Specify the default rpm macros in terms of adjustable variables |
| 125 | rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros" |
| 126 | rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros" |
| 127 | rpm_macros_class-nativesdk = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros" |
| 128 | |
| 129 | # sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux |
| 130 | |
| 131 | # Note: perl and sqlite w/o db specified does not currently work. |
| 132 | # tcl, augeas, nss, gcrypt, xar and keyutils support is untested. |
| 133 | PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python" |
| 134 | |
| 135 | PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2," |
| 136 | PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz," |
| 137 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," |
| 138 | PACKAGECONFIG[xar] = "--with-xar,--without-xar,xar," |
| 139 | |
| 140 | WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \ |
| 141 | --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ |
| 142 | --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \ |
| 143 | --without-pythonembed" |
| 144 | PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python," |
| 145 | |
| 146 | # Perl modules are not built, but they could be enabled fairly easily |
| 147 | # the perl module creation and installation would need to be patched. |
| 148 | # (currently has host perl contamination issues) |
| 149 | WITH_PERL = "--with-perl --without-perlembed --without-perl-urpm" |
| 150 | WITHOUT_PERL = "--without-perl --without-perl-urpm" |
| 151 | PACKAGECONFIG[perl] = "${WITH_PERL},${WITHOUT_PERL},perl," |
| 152 | |
| 153 | # The --with-dbsql will only tell RPM to check for support, db |
| 154 | # may or may not be built w/ the dbsql support. |
| 155 | WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated" |
| 156 | PACKAGECONFIG[db] = "${WITH_DB},--without-db,db," |
| 157 | |
| 158 | PACKAGECONFIG[sqlite] = "--with-sqlite,--without-sqlite,sqlite3," |
| 159 | |
| 160 | PACKAGECONFIG[beecrypt] = "--with-beecrypt=external,--without-beecrypt,beecrypt," |
| 161 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," |
| 162 | PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss," |
| 163 | PACKAGECONFIG[gcrypt] = "--with-gcrypt,--without-gcrypt,gcrypt," |
| 164 | PACKAGECONFIG[keyutils] = "--with-keyutils,--without-keyutils,keyutils," |
| 165 | PACKAGECONFIG[libelf] = "--with-libelf,--without-libelf,elfutils," |
| 166 | |
| 167 | WITH_SELINUX = "--with-selinux --with-sepol --with-semanage" |
| 168 | WITHOUT_SELINUX = "--without-selinux --without-sepol --without-semanage" |
| 169 | PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},libselinux," |
| 170 | |
| 171 | WITH_NEON = "--with-neon --with-libproxy --with-expat --without-gssapi" |
| 172 | WITHOUT_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi" |
| 173 | PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon expat," |
| 174 | |
| 175 | PACKAGECONFIG[lua] = "--with-lua,--without-lua,expat," |
| 176 | PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl," |
| 177 | |
| 178 | PACKAGECONFIG[augeas] = "--with-augeas,--without-augeas,augeas," |
| 179 | |
| 180 | EXTRA_OECONF += "--verbose \ |
| 181 | --sysconfdir=${sysconfdir} \ |
| 182 | --with-file \ |
| 183 | --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \ |
| 184 | --with-syck=internal \ |
| 185 | --without-readline \ |
| 186 | --without-libtasn1 \ |
| 187 | --without-pakchois \ |
| 188 | --without-gnutls \ |
| 189 | --with-pcre \ |
| 190 | --enable-utf8 \ |
| 191 | --with-uuid \ |
| 192 | --with-attr \ |
| 193 | --with-acl \ |
| 194 | --with-popt=external \ |
| 195 | --with-pthreads \ |
| 196 | --without-cudf \ |
| 197 | --without-ficl \ |
| 198 | --without-aterm \ |
| 199 | --without-nix \ |
| 200 | --without-bash \ |
| 201 | --without-rc \ |
| 202 | --without-js \ |
| 203 | --without-gpsee \ |
| 204 | --without-ruby \ |
| 205 | --without-squirrel \ |
| 206 | --with-build-extlibdep \ |
| 207 | --with-build-maxextlibdep \ |
| 208 | --without-valgrind \ |
| 209 | --disable-openmp \ |
| 210 | --enable-build-pic \ |
| 211 | --enable-build-versionscript \ |
| 212 | --enable-build-warnings \ |
| 213 | --enable-build-debug \ |
| 214 | --enable-maintainer-mode \ |
| 215 | --with-path-macros=${rpm_macros} \ |
| 216 | --with-path-lib=${libdir}/rpm \ |
| 217 | --with-bugreport=http://bugzilla.yoctoproject.org \ |
| 218 | --program-prefix= \ |
| 219 | YACC=byacc" |
| 220 | |
| 221 | CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE" |
| 222 | |
| 223 | LDFLAGS_append_libc-uclibc = "-lrt -lpthread" |
| 224 | |
| 225 | PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm-dev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale" |
| 226 | |
| 227 | SOLIBS = "5.4.so" |
| 228 | |
| 229 | # Based on %files section in the rpm.spec |
| 230 | |
| 231 | FILES_${PN} = "${bindir}/rpm \ |
| 232 | ${bindir}/rpmconstant \ |
| 233 | ${libdir}/rpm/rpm.* \ |
| 234 | ${libdir}/rpm/tgpg \ |
| 235 | ${libdir}/rpm/macros \ |
| 236 | ${libdir}/rpm/rpmpopt \ |
| 237 | ${libdir}/rpm/rpm2cpio \ |
| 238 | ${libdir}/rpm/vcheck \ |
| 239 | ${libdir}/rpm/helpers \ |
| 240 | ${libdir}/rpm/qf \ |
| 241 | ${libdir}/rpm/cpuinfo.yaml \ |
| 242 | ${libdir}/rpm/bin/mtree \ |
| 243 | ${libdir}/rpm/bin/rpmkey \ |
| 244 | ${libdir}/rpm/bin/rpmrepo \ |
| 245 | ${libdir}/rpm/bin/rpmrepo.real \ |
| 246 | ${libdir}/rpm/bin/rpmspecdump \ |
| 247 | ${libdir}/rpm/bin/rpmspecdump.real \ |
| 248 | ${libdir}/rpm/bin/wget \ |
| 249 | ${localstatedir}/cache \ |
| 250 | ${localstatedir}/cache/rpm \ |
| 251 | ${localstatedir}/cache/wdj \ |
| 252 | ${localstatedir}/lib \ |
| 253 | ${localstatedir}/lib/rpm \ |
| 254 | ${localstatedir}/lib/wdj \ |
| 255 | ${bindir}/rpm.real \ |
| 256 | ${bindir}/rpmconstant.real \ |
| 257 | ${bindir}/rpm2cpio.real \ |
| 258 | " |
| 259 | |
| 260 | FILES_${PN}-dbg += "${libdir}/rpm/.debug \ |
| 261 | ${libdir}/rpm/bin/.debug \ |
| 262 | " |
| 263 | |
| 264 | FILES_${PN}-common = "${bindir}/rpm2cpio \ |
| 265 | ${bindir}/gendiff \ |
| 266 | ${sysconfdir}/rpm \ |
| 267 | ${localstatedir}/spool/repackage \ |
| 268 | " |
| 269 | |
| 270 | FILES_${PN}-libs = "${libdir}/librpm-*.so \ |
| 271 | ${libdir}/librpmconstant-*.so \ |
| 272 | ${libdir}/librpmdb-*.so \ |
| 273 | ${libdir}/librpmio-*.so \ |
| 274 | ${libdir}/librpmmisc-*.so \ |
| 275 | ${libdir}/librpmbuild-*.so \ |
| 276 | " |
| 277 | |
| 278 | FILES_${PN}-build = "${prefix}/src/rpm \ |
| 279 | ${bindir}/rpmbuild \ |
| 280 | ${bindir}/rpmbuild.real \ |
| 281 | ${libdir}/rpm/brp-* \ |
| 282 | ${libdir}/rpm/check-files \ |
| 283 | ${libdir}/rpm/cross-build \ |
| 284 | ${libdir}/rpm/find-debuginfo.sh \ |
| 285 | ${libdir}/rpm/find-lang.sh \ |
| 286 | ${libdir}/rpm/find-prov.pl \ |
| 287 | ${libdir}/rpm/find-provides.perl \ |
| 288 | ${libdir}/rpm/find-req.pl \ |
| 289 | ${libdir}/rpm/find-requires.perl \ |
| 290 | ${libdir}/rpm/getpo.sh \ |
| 291 | ${libdir}/rpm/http.req \ |
| 292 | ${libdir}/rpm/javadeps.sh \ |
| 293 | ${libdir}/rpm/mono-find-provides \ |
| 294 | ${libdir}/rpm/mono-find-requires \ |
| 295 | ${libdir}/rpm/executabledeps.sh \ |
| 296 | ${libdir}/rpm/libtooldeps.sh \ |
| 297 | ${libdir}/rpm/osgideps.pl \ |
| 298 | ${libdir}/rpm/perldeps.pl \ |
| 299 | ${libdir}/rpm/perl.prov \ |
| 300 | ${libdir}/rpm/perl.req \ |
| 301 | ${libdir}/rpm/php.prov \ |
| 302 | ${libdir}/rpm/php.req \ |
| 303 | ${libdir}/rpm/pkgconfigdeps.sh \ |
| 304 | ${libdir}/rpm/pythondeps.sh \ |
| 305 | ${libdir}/rpm/bin/debugedit \ |
| 306 | ${libdir}/rpm/bin/debugedit.real \ |
| 307 | ${libdir}/rpm/bin/rpmcache \ |
| 308 | ${libdir}/rpm/bin/rpmcache.real \ |
| 309 | ${libdir}/rpm/bin/rpmcmp \ |
| 310 | ${libdir}/rpm/bin/rpmcmp.real \ |
| 311 | ${libdir}/rpm/bin/rpmdeps \ |
| 312 | ${libdir}/rpm/bin/rpmdeps.real \ |
| 313 | ${libdir}/rpm/bin/rpmdeps-oecore \ |
| 314 | ${libdir}/rpm/bin/rpmdeps-oecore.real \ |
| 315 | ${libdir}/rpm/bin/rpmdigest \ |
| 316 | ${libdir}/rpm/bin/rpmdigest.real \ |
| 317 | ${libdir}/rpm/bin/abi-compliance-checker.pl \ |
| 318 | ${libdir}/rpm/bin/api-sanity-autotest.pl \ |
| 319 | ${libdir}/rpm/bin/chroot \ |
| 320 | ${libdir}/rpm/bin/cp \ |
| 321 | ${libdir}/rpm/bin/dbsql \ |
| 322 | ${libdir}/rpm/bin/find \ |
| 323 | ${libdir}/rpm/bin/install-sh \ |
| 324 | ${libdir}/rpm/bin/lua \ |
| 325 | ${libdir}/rpm/bin/luac \ |
| 326 | ${libdir}/rpm/bin/mkinstalldirs \ |
| 327 | ${libdir}/rpm/bin/rpmlua \ |
| 328 | ${libdir}/rpm/bin/rpmluac \ |
| 329 | ${libdir}/rpm/bin/sqlite3 \ |
| 330 | ${libdir}/rpm/macros.d/cmake \ |
| 331 | ${libdir}/rpm/macros.d/java \ |
| 332 | ${libdir}/rpm/macros.d/libtool \ |
| 333 | ${libdir}/rpm/macros.d/mandriva \ |
| 334 | ${libdir}/rpm/macros.d/mono \ |
| 335 | ${libdir}/rpm/macros.d/perl \ |
| 336 | ${libdir}/rpm/macros.d/php \ |
| 337 | ${libdir}/rpm/macros.d/pkgconfig \ |
| 338 | ${libdir}/rpm/macros.d/python \ |
| 339 | ${libdir}/rpm/macros.d/ruby \ |
| 340 | ${libdir}/rpm/macros.d/selinux \ |
| 341 | ${libdir}/rpm/macros.d/tcl \ |
| 342 | ${libdir}/rpm/macros.rpmbuild \ |
| 343 | ${libdir}/rpm/u_pkg.sh \ |
| 344 | ${libdir}/rpm/vpkg-provides.sh \ |
| 345 | ${libdir}/rpm/vpkg-provides2.sh \ |
| 346 | ${libdir}/rpm/perfile_rpmdeps.sh \ |
| 347 | " |
| 348 | RDEPENDS_${PN} = "base-files run-postinsts" |
| 349 | RDEPENDS_${PN}_class-native = "" |
| 350 | RDEPENDS_${PN}_class-nativesdk = "" |
| 351 | RDEPENDS_${PN}-build = "file bash perl" |
| 352 | |
| 353 | RDEPENDS_python-rpm = "${PN}" |
| 354 | |
| 355 | FILES_python-rpm-dbg = "${libdir}/python*/site-packages/rpm/.debug/_*" |
| 356 | FILES_python-rpm-dev = "${libdir}/python*/site-packages/rpm/*.la" |
| 357 | FILES_python-rpm-staticdev = "${libdir}/python*/site-packages/rpm/*.a" |
| 358 | FILES_python-rpm = "${libdir}/python*/site-packages/rpm" |
| 359 | |
| 360 | FILES_perl-module-rpm = "${libdir}/perl/*/* \ |
| 361 | " |
| 362 | |
| 363 | FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \ |
| 364 | " |
| 365 | |
| 366 | RDEPENDS_${PN}-dev += "bash" |
| 367 | |
| 368 | FILES_${PN}-dev = "${includedir}/rpm \ |
| 369 | ${libdir}/librpm.la \ |
| 370 | ${libdir}/librpm.so \ |
| 371 | ${libdir}/librpmconstant.la \ |
| 372 | ${libdir}/librpmconstant.so \ |
| 373 | ${libdir}/librpmdb.la \ |
| 374 | ${libdir}/librpmdb.so \ |
| 375 | ${libdir}/librpmio.la \ |
| 376 | ${libdir}/librpmio.so \ |
| 377 | ${libdir}/librpmmisc.la \ |
| 378 | ${libdir}/librpmmisc.so \ |
| 379 | ${libdir}/librpmbuild.la \ |
| 380 | ${libdir}/librpmbuild.so \ |
| 381 | ${libdir}/rpm/lib/liblua.la \ |
| 382 | ${libdir}/pkgconfig/rpm.pc \ |
| 383 | ${libdir}/rpm/rpmdb_loadcvt \ |
| 384 | " |
| 385 | |
| 386 | FILES_${PN}-staticdev = " \ |
| 387 | ${libdir}/librpm.a \ |
| 388 | ${libdir}/librpmconstant.a \ |
| 389 | ${libdir}/librpmdb.a \ |
| 390 | ${libdir}/librpmio.a \ |
| 391 | ${libdir}/librpmmisc.a \ |
| 392 | ${libdir}/librpmbuild.a \ |
| 393 | ${libdir}/rpm/lib/liblua.a \ |
| 394 | " |
| 395 | |
| 396 | do_configure() { |
| 397 | # Disable tests! |
| 398 | echo "all:" > ${S}/tests/Makefile.am |
| 399 | sed -e 's/@__MKDIR_P@/%{__mkdir} -p/' -i ${S}/macros/macros.in |
| 400 | |
| 401 | ( cd ${S}; ${S}/autogen.sh ) |
| 402 | |
| 403 | # NASTY hack to make sure configure files the right pkg-config file... |
| 404 | sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \ |
| 405 | -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure |
| 406 | |
| 407 | ( cd ${S}/syck ; set +e ; rm -- -l* ; make distclean ) || : |
| 408 | |
| 409 | export varprefix=${localstatedir} |
| 410 | oe_runconf |
| 411 | } |
| 412 | |
| 413 | do_install_append() { |
| 414 | sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros |
| 415 | sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/* |
| 416 | sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/* |
| 417 | sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros |
| 418 | sed -i -e 's,^#%_openall_before_chroot.*,%_openall_before_chroot\t1,' ${D}/${libdir}/rpm/macros |
| 419 | |
| 420 | # Enable Debian style arbitrary tags... |
| 421 | sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros |
| 422 | |
| 423 | install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh |
| 424 | install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh |
| 425 | |
| 426 | # Remove unpackaged files (based on list in rpm.spec) |
| 427 | rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm} |
| 428 | |
| 429 | rm -f ${D}/${mandir}/man8/rpmcache.8* |
| 430 | rm -f ${D}/${mandir}/man8/rpmgraph.8* |
| 431 | rm -f ${D}/${mandir}/*/man8/rpmcache.8* |
| 432 | rm -f ${D}/${mandir}/*/man8/rpmgraph.8* |
| 433 | rm -rf ${D}/${mandir}/{fr,ko} |
| 434 | |
| 435 | rm -f ${D}/${includedir}/popt.h |
| 436 | rm -f ${D}/${libdir}/libpopt.* |
| 437 | rm -f ${D}/${libdir}/pkgconfig/popt.pc |
| 438 | rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo |
| 439 | rm -f ${D}/${mandir}/man3/popt.3 |
| 440 | |
| 441 | rm -f ${D}/${mandir}/man1/xar.1* |
| 442 | rm -f ${D}/${bindir}/xar |
| 443 | rm -rf ${D}/${includedir}/xar |
| 444 | rm -f ${D}/${libdir}/libxar* |
| 445 | |
| 446 | rm -f ${D}/${bindir}/lz* |
| 447 | rm -f ${D}/${bindir}/unlzma |
| 448 | rm -f ${D}/${bindir}/unxz |
| 449 | rm -f ${D}/${bindir}/xz* |
| 450 | rm -rf ${D}/${includedir}/lzma* |
| 451 | rm -f ${D}/${mandir}/man1/lz*.1 |
| 452 | rm -f ${D}/${libdir}/pkgconfig/liblzma* |
| 453 | |
| 454 | rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la} |
| 455 | rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la} |
| 456 | |
| 457 | #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \ |
| 458 | # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';' |
| 459 | #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';' |
| 460 | |
| 461 | # We don't want the default macro set |
| 462 | rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*} |
| 463 | |
| 464 | rm -f ${D}/${libdir}/rpm/dbconvert.sh |
| 465 | |
| 466 | rm -f ${D}/${libdir}/rpm/libsqldb.* |
| 467 | |
| 468 | # We don't want, nor need the Mandriva multiarch items |
| 469 | rm -f ${D}/${bindir}/multiarch-dispatch |
| 470 | rm -f ${D}/${bindir}/multiarch-platform |
| 471 | rm -f ${D}/${libdir}/rpm/check-multiarch-files |
| 472 | rm -f ${D}/${libdir}/rpm/mkmultiarch |
| 473 | rm -f ${D}/${includedir}/multiarch-dispatch.h |
| 474 | |
| 475 | rm -f ${D}/${libdir}/rpm/gstreamer.sh |
| 476 | rm -f ${D}/${libdir}/rpm/gem_helper.rb |
| 477 | rm -f ${D}/${libdir}/rpm/rubygems.rb |
| 478 | rm -f ${D}/${libdir}/rpm/kmod-deps.sh |
| 479 | rm -f ${D}/${libdir}/rpm/pythoneggs.py |
| 480 | rm -f ${D}/${libdir}/rpm/macros.d/kernel |
| 481 | rm -f ${D}/${libdir}/rpm/macros.d/gstreamer |
| 482 | rm -f ${D}/${libdir}/rpm/bin/mgo |
| 483 | rm -f ${D}/${libdir}/rpm/bin/dbconvert |
| 484 | rm -f ${D}/${libdir}/rpm/bin/pom2spec |
| 485 | |
| 486 | rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj |
| 487 | rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl |
| 488 | |
| 489 | } |
| 490 | |
| 491 | add_native_wrapper() { |
| 492 | create_wrapper ${D}/${bindir}/rpm \ |
| 493 | RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ |
| 494 | RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ |
| 495 | RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale |
| 496 | |
| 497 | create_wrapper ${D}/${bindir}/rpm2cpio \ |
| 498 | RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ |
| 499 | RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ |
| 500 | RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale |
| 501 | |
| 502 | create_wrapper ${D}/${bindir}/rpmbuild \ |
| 503 | RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ |
| 504 | RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ |
| 505 | RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale |
| 506 | |
| 507 | create_wrapper ${D}/${bindir}/rpmconstant \ |
| 508 | RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ |
| 509 | RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ |
| 510 | RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale |
| 511 | |
| 512 | for rpm_binary in ${D}/${libdir}/rpm/bin/rpm* ${D}/${libdir}/rpm/bin/debugedit; do |
| 513 | create_wrapper $rpm_binary \ |
| 514 | RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ |
| 515 | RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ |
| 516 | RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale |
| 517 | done |
| 518 | } |
| 519 | |
| 520 | do_install_append_class-native() { |
| 521 | add_native_wrapper |
| 522 | } |
| 523 | |
| 524 | do_install_append_class-nativesdk() { |
| 525 | add_native_wrapper |
| 526 | } |
| 527 | |
| 528 | BBCLASSEXTEND = "native nativesdk" |