Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Multi-purpose linux bootloader" |
| 2 | HOMEPAGE = "http://syslinux.zytor.com/" |
| 3 | LICENSE = "GPLv2+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 5 | file://README;beginline=35;endline=41;md5=558f2c71cb1fb9ba511ccd4858e48e8a" |
| 6 | |
| 7 | # If you really want to run syslinux, you need mtools. We just want the |
| 8 | # ldlinux.* stuff for now, so skip mtools-native |
| 9 | DEPENDS = "nasm-native util-linux e2fsprogs" |
| 10 | |
| 11 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/boot/syslinux/syslinux-${PV}.tar.xz \ |
| 12 | file://syslinux-fix-parallel-building-issue.patch \ |
| 13 | file://syslinux-libupload-depend-lib.patch \ |
| 14 | file://syslinux-remove-clean-script.patch \ |
| 15 | file://0001-linux-syslinux-support-ext2-3-4-device.patch \ |
| 16 | file://0002-linux-syslinux-implement-open_ext2_fs.patch \ |
| 17 | file://0003-linux-syslinux-implement-install_to_ext2.patch \ |
| 18 | file://0004-linux-syslinux-add-ext_file_read-and-ext_file_write.patch \ |
| 19 | file://0005-linux-syslinux-implement-handle_adv_on_ext.patch \ |
| 20 | file://0006-linux-syslinux-implement-write_to_ext-and-add-syslin.patch \ |
| 21 | file://0007-linux-syslinux-implement-ext_construct_sectmap_fs.patch \ |
| 22 | file://0008-libinstaller-syslinuxext-implement-syslinux_patch_bo.patch \ |
| 23 | file://0009-linux-syslinux-implement-install_bootblock.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[md5sum] = "92a253df9211e9c20172796ecf388f13" |
| 27 | SRC_URI[sha256sum] = "26d3986d2bea109d5dc0e4f8c4822a459276cf021125e8c9f23c3cca5d8c850e" |
| 28 | |
| 29 | COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)' |
| 30 | # Don't let the sanity checker trip on the 32 bit real mode BIOS binaries |
| 31 | INSANE_SKIP_${PN}-misc = "arch" |
| 32 | INSANE_SKIP_${PN}-chain = "arch" |
| 33 | |
| 34 | EXTRA_OEMAKE = " \ |
| 35 | BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \ |
| 36 | DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \ |
| 37 | " |
| 38 | # syslinux uses $LD for linking, strip `-Wl,' so it can work |
| 39 | export LDFLAGS = "`echo $LDFLAGS | sed 's/-Wl,//g'`" |
| 40 | |
| 41 | do_configure() { |
| 42 | # drop win32 targets or build fails |
| 43 | sed -e 's,win32/\S*,,g' -i Makefile |
| 44 | |
| 45 | # clean installer executables included in source tarball |
| 46 | oe_runmake clean firmware="efi32" EFIINC="${includedir}" |
| 47 | # NOTE: There is a temporary work around above to specify |
| 48 | # the efi32 as the firmware else the pre-built bios |
| 49 | # files get erased contrary to the doc/distib.txt |
| 50 | # In the future this should be "bios" and not "efi32". |
| 51 | } |
| 52 | |
| 53 | do_compile() { |
| 54 | # Make sure the recompile is OK. |
| 55 | # Though the ${B} should always exist, still check it before find and rm. |
| 56 | [ -d "${B}" ] && find ${B} -name '.*.d' -type f -exec rm -f {} \; |
| 57 | |
| 58 | # Rebuild only the installer; keep precompiled bootloaders |
| 59 | # as per author's request (doc/distrib.txt) |
| 60 | oe_runmake CC="${CC} ${CFLAGS}" LDFLAGS="${LDFLAGS}" firmware="bios" installer |
| 61 | } |
| 62 | |
| 63 | do_install() { |
| 64 | oe_runmake CC="${CC} ${CFLAGS}" install INSTALLROOT="${D}" firmware="bios" |
| 65 | |
| 66 | install -d ${D}${datadir}/syslinux/ |
| 67 | install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/ |
| 68 | install -m 644 ${S}/bios/core/ldlinux.bss ${D}${datadir}/syslinux/ |
| 69 | install -m 755 ${S}/bios/linux/syslinux-nomtools ${D}${bindir}/ |
| 70 | } |
| 71 | |
| 72 | PACKAGES += "${PN}-nomtools ${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc" |
| 73 | |
| 74 | RDEPENDS_${PN} += "mtools" |
| 75 | RDEPENDS_${PN}-nomtools += "libext2fs" |
| 76 | RDEPENDS_${PN}-misc += "perl" |
| 77 | |
| 78 | FILES_${PN} = "${bindir}/syslinux" |
| 79 | FILES_${PN}-nomtools = "${bindir}/syslinux-nomtools" |
| 80 | FILES_${PN}-extlinux = "${sbindir}/extlinux" |
| 81 | FILES_${PN}-mbr = "${datadir}/${BPN}/mbr.bin" |
| 82 | FILES_${PN}-chain = "${datadir}/${BPN}/chain.c32" |
| 83 | FILES_${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin" |
| 84 | FILES_${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0" |
| 85 | FILES_${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld" |
| 86 | FILES_${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a" |
| 87 | FILES_${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*" |
| 88 | |
| 89 | BBCLASSEXTEND = "native nativesdk" |