Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Simple DirectMedia Layer" |
| 2 | DESCRIPTION = "Simple DirectMedia Layer is a cross-platform multimedia \ |
| 3 | library designed to provide low level access to audio, keyboard, mouse, \ |
| 4 | joystick, 3D hardware via OpenGL, and 2D video framebuffer." |
| 5 | HOMEPAGE = "http://www.libsdl.org" |
| 6 | BUGTRACKER = "http://bugzilla.libsdl.org/" |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "LGPLv2.1" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=27818cd7fd83877a8e3ef82b82798ef4" |
| 12 | |
| 13 | PROVIDES = "virtual/libsdl" |
| 14 | |
| 15 | DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \ |
| 16 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virtual/libgl libglu', '', d)} \ |
| 17 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11 libxext libxrandr libxrender', '', d)} \ |
| 18 | tslib" |
| 19 | DEPENDS_class-nativesdk = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/nativesdk-libx11 nativesdk-libxrandr nativesdk-libxrender nativesdk-libxext', '', d)}" |
| 20 | |
| 21 | PR = "r3" |
| 22 | |
| 23 | SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \ |
| 24 | file://configure_tweak.patch \ |
| 25 | file://libsdl-1.2.15-xdata32.patch \ |
| 26 | file://pkgconfig.patch \ |
| 27 | " |
| 28 | |
| 29 | S = "${WORKDIR}/SDL-${PV}" |
| 30 | |
| 31 | SRC_URI[md5sum] = "9d96df8417572a2afb781a7c4c811a85" |
| 32 | SRC_URI[sha256sum] = "d6d316a793e5e348155f0dd93b979798933fb98aa1edebcc108829d6474aad00" |
| 33 | |
| 34 | BINCONFIG = "${bindir}/sdl-config" |
| 35 | |
| 36 | inherit autotools lib_package binconfig-disabled pkgconfig |
| 37 | |
| 38 | EXTRA_OECONF = "--disable-static --enable-cdrom --enable-threads --enable-timers \ |
| 39 | --enable-file --disable-oss --disable-esd --disable-arts \ |
| 40 | --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \ |
| 41 | --disable-mintaudio --disable-nasm --disable-video-dga \ |
| 42 | --disable-video-fbcon --disable-video-ps2gs --disable-video-ps3 \ |
| 43 | --disable-xbios --disable-gem --disable-video-dummy \ |
| 44 | --enable-input-events --enable-input-tslib --enable-pthreads \ |
| 45 | ${@bb.utils.contains('DISTRO_FEATURES', 'directfb', '--enable-video-directfb', '--disable-video-directfb', d)} \ |
| 46 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '--enable-video-opengl', '--disable-video-opengl', d)} \ |
| 47 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--enable-video-x11', '--disable-video-x11', d)} \ |
| 48 | --disable-video-svga \ |
| 49 | --disable-video-picogui --disable-video-qtopia --enable-sdl-dlopen \ |
| 50 | --disable-rpath \ |
| 51 | --disable-pulseaudio" |
| 52 | |
| 53 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}" |
| 54 | PACKAGECONFIG[alsa] = "--enable-alsa --disable-alsatest,--disable-alsa,alsa-lib," |
| 55 | |
| 56 | EXTRA_AUTORECONF += "--include=acinclude --exclude=autoheader" |
| 57 | |
| 58 | do_configure_prepend() { |
| 59 | # Remove old libtool macros. |
| 60 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 61 | for i in ${MACROS}; do |
| 62 | rm -f ${S}/acinclude/$i |
| 63 | done |
| 64 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR |
| 65 | } |
| 66 | |
| 67 | BBCLASSEXTEND = "nativesdk" |