Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | SUMMARY = "Touchscreen calibration data from xinput-calibrator" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 4 | |
| 5 | PR = "r7" |
| 6 | |
| 7 | SRC_URI = "file://pointercal.xinput" |
| 8 | S = "${WORKDIR}" |
| 9 | |
| 10 | do_install() { |
| 11 | # Only install file if it has a contents |
| 12 | if [ -s ${S}/pointercal.xinput ] &&\ |
| 13 | [ ! -n "$(head -n1 ${S}/pointercal.xinput|grep "replace.*pointercal\.xinput")" ]; then |
| 14 | install -d ${D}${sysconfdir}/ |
| 15 | install -m 0644 ${S}/pointercal.xinput ${D}${sysconfdir}/ |
| 16 | fi |
| 17 | } |
| 18 | |
| 19 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 20 | CONFFILES_${PN} = "${sysconfdir}/pointercal.xinput" |