Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame^] | 1 | require xorg-driver-video.inc |
| 2 | |
| 3 | SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver" |
| 4 | |
| 5 | DESCRIPTION = "omapfb driver supports the basic Texas Instruments OMAP \ |
| 6 | framebuffer." |
| 7 | |
| 8 | LICENSE = "MIT-X & GPLv2+" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=63e2cbac53863f60e2f43343fb34367f" |
| 10 | DEPENDS += "virtual/libx11" |
| 11 | |
| 12 | SRCREV = "33e36c12dde336edbdd34626dd8adfcaebc8fbb8" |
| 13 | PR = "${INC_PR}.7" |
| 14 | PV = "0.1.1+gitr${SRCPV}" |
| 15 | |
| 16 | SRC_URI = "git://anonscm.debian.org/collab-maint/xf86-video-omapfb.git \ |
| 17 | file://0001-Prevents-omapfb-from-from-crashing-when-pixelclock-o.patch \ |
| 18 | file://0001-Revert-Set-a-large-CRTC-upper-limit-to-not-prune-lar.patch \ |
| 19 | file://0002-Revert-Set-virtual-size-when-configuring-framebuffer.patch \ |
| 20 | file://0003-force-plain-mode.patch \ |
| 21 | file://0004-blacklist-tv-out.patch \ |
| 22 | file://0005-Attempt-to-fix-VRFB.patch \ |
| 23 | file://0006-omapfb-port-to-new-xserver-video-API.patch \ |
| 24 | file://0007-always_include_xorg_server.h.patch \ |
| 25 | " |
| 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | |
| 29 | EXTRA_OECONF_armv7a = " --enable-neon " |
| 30 | CFLAGS += " -I${STAGING_INCDIR}/xorg " |
| 31 | |
| 32 | # Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay) |
| 33 | do_compile_prepend_armv7a () { |
| 34 | sed -i -e s:fb1:fb2:g ${S}/src/omapfb-xv.c |
| 35 | } |