blob: 10c9170fb1013efa757d44707c66bbb1c6ca7f1a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Client for Microsoft PPTP VPNs"
2DESCRIPTION = "PPTP Client is a Linux, FreeBSD, NetBSD \
3 and OpenBSD client for the proprietary Microsoft Point-to-Point \
4 Tunneling Protocol, PPTP. Allows connection to a PPTP based \
5 Virtual Private Network (VPN) as used by employers and some \
6 cable and ADSL internet service providers."
7HOMEPAGE = "http://pptpclient.sourceforge.net"
8SECTION = "net"
9LICENSE = "GPLv2+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/sourceforge/pptpclient/pptp-${PV}.tar.gz \
13 file://options.pptp \
14 file://0001-include-missing-sys-types.h.patch \
15 "
16
17SRC_URI[md5sum] = "b2117b377f65294a9786f80f0235d308"
18SRC_URI[sha256sum] = "0b1e8cbfc578d3f5ab12ee87c5c2c60419abfe9cc445690a8a19c320b11c9201"
19
20S = "${WORKDIR}/pptp-${PV}"
21
22EXTRA_OEMAKE = "-e MAKEFLAGS="
23
24do_install() {
25 install -d ${D}${sbindir} ${D}${sysconfdir}/ppp ${D}${mandir}/man8
26 install -m 555 pptp ${D}${sbindir}
27 install -m 644 pptp.8 ${D}${mandir}/man8
28 install -m 644 ${WORKDIR}/options.pptp ${D}${sysconfdir}/ppp
29}
30
31RDEPENDS_${PN} = "ppp"