Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "An IPC library for high performance servers" |
| 2 | DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \ |
| 3 | It provides high performance logging, tracing, ipc, and poll." |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "LGPL-2.1" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785" |
| 9 | |
| 10 | inherit autotools pkgconfig |
| 11 | |
| 12 | PV .= "+git${SRCPV}" |
| 13 | |
| 14 | # v1.0.3 |
| 15 | SRCREV = "28dff090c74b6ba8609c4797294a5afe3fe73987" |
| 16 | SRC_URI = "git://github.com/ClusterLabs/${BPN}.git \ |
| 17 | file://0001-build-fix-configure-script-neglecting-re-enable-out-.patch \ |
| 18 | " |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 21 | # otherwise do_configure fails |
| 22 | # configure:21609: checking whether linker workaround for orphan sections usable |
| 23 | # configure:21639: i586-oe-linux-gcc -m32 -march=i586 --sysroot=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot -o conftest -O -fno-omit-frame-pointer -g -feliminate-unused-debug-types -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0=/usr/src/debug/libqb/1.0.3+gitAUTOINC+c235284b5f-r0 -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot= -fdebug-prefix-map=WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native= -pipe -pthread -D_REENTRANT -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,conftest.ld conftest.c >&5 |
| 24 | # WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: error: conftest.ld: SECTIONS seen after other input files; try -T/--script |
| 25 | # WORKDIR/libqb/1.0.3+gitAUTOINC+c235284b5f-r0/recipe-sysroot-native/usr/bin/i586-oe-linux/../../libexec/i586-oe-linux/gcc/i586-oe-linux/8.1.0/ld: internal error in write_sections, at ../../gold/reloc.cc:791 |
| 26 | # collect2: error: ld returned 1 exit status |
| 27 | EXTRA_OECONF_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' --enable-nosection-fallback', '', d)}" |
| 28 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | CFLAGS += "-pthread -D_REENTRANT" |
| 30 | do_configure_prepend() { |
| 31 | ( cd ${S} |
| 32 | ${S}/autogen.sh ) |
| 33 | } |