Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Control and monitor storage systems using S.M.A.R.T" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 2 | DESCRIPTION = "\ |
| 3 | The smartmontools package contains two utility programs (smartctl \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | and smartd) to control and monitor storage systems using the Self-\ |
| 5 | Monitoring, Analysis and Reporting Technology System (SMART) built \ |
| 6 | into most modern ATA and SCSI hard disks. In many cases, these \ |
| 7 | utilities will provide advanced warning of disk degradation and failure." |
| 8 | |
| 9 | HOMEPAGE = "http://smartmontools.sourceforge.net/" |
| 10 | SECTION = "console/utils" |
| 11 | |
| 12 | LICENSE = "GPLv2" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 14 | |
| 15 | SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | file://initd.smartd \ |
| 17 | file://smartmontools.default \ |
| 18 | file://smartd.service \ |
| 19 | file://0001-os_linux.cpp-Use-realpath-BSD-POSIX-instead-of-canon.patch \ |
| 20 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | |
| 22 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)}" |
| 23 | PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng" |
| 24 | PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux" |
| 25 | |
| 26 | SRC_URI[md5sum] = "9ae2c6e7131cd2813edcc65cbe5f223f" |
| 27 | SRC_URI[sha256sum] = "51f43d0fb064fccaf823bbe68cf0d317d0895ff895aa353b3339a3b316a53054" |
| 28 | |
| 29 | inherit autotools update-rc.d systemd |
| 30 | |
| 31 | SYSTEMD_SERVICE_${PN} = "smartd.service" |
| 32 | SYSTEMD_AUTO_ENABLE = "disable" |
| 33 | |
| 34 | do_install_append () { |
| 35 | #install the init.d/smartd |
| 36 | install -d ${D}${sysconfdir}/init.d |
| 37 | install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd |
| 38 | install -d ${D}${sysconfdir}/default |
| 39 | install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools |
| 40 | |
| 41 | #install systemd service file |
| 42 | install -d ${D}${systemd_unitdir}/system |
| 43 | install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system |
| 44 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 45 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 46 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 47 | ${D}${systemd_unitdir}/system/smartd.service |
| 48 | } |
| 49 | |
| 50 | INITSCRIPT_NAME = "smartd" |
| 51 | INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ." |
| 52 | |
| 53 | RDEPENDS_${PN} += "mailx" |