Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Software stack for TPM2." |
| 2 | DESCRIPTION = "OSS implementation of the TCG TPM2 Software Stack (TSS2) " |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=500b2e742befc3da00684d8a1d5fd9da" |
| 5 | SECTION = "tpm" |
| 6 | |
| 7 | DEPENDS = "autoconf-archive-native libgcrypt openssl" |
| 8 | |
Brad Bishop | a3b01f4 | 2019-09-13 06:30:46 -0400 | [diff] [blame] | 9 | SRCREV = "a99e733ba66c359502689a9c42fd5e02ed1dd7d6" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
Brad Bishop | a3b01f4 | 2019-09-13 06:30:46 -0400 | [diff] [blame] | 11 | SRC_URI = "git://github.com/tpm2-software/tpm2-tss.git;branch=2.3.x" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
| 13 | inherit autotools-brokensep pkgconfig systemd |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[oxygen] = ",--disable-doxygen-doc, " |
| 19 | |
Brad Bishop | 95dbbac | 2019-12-02 13:55:25 -0500 | [diff] [blame] | 20 | EXTRA_OECONF += "--with-udevrulesdir=${base_prefix}/lib/udev/rules.d/" |
| 21 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | do_configure_prepend () { |
| 23 | ./bootstrap |
| 24 | } |
| 25 | |
| 26 | INHERIT += "extrausers" |
| 27 | EXTRA_USERS_PARAMS = "\ |
| 28 | useradd -p '' tss; \ |
| 29 | groupadd tss; \ |
| 30 | " |
| 31 | |
| 32 | PROVIDES = "${PACKAGES}" |
| 33 | PACKAGES = " \ |
| 34 | ${PN} \ |
| 35 | ${PN}-dbg \ |
| 36 | ${PN}-doc \ |
| 37 | libtss2-mu \ |
| 38 | libtss2-mu-dev \ |
| 39 | libtss2-mu-staticdev \ |
| 40 | libtss2-tcti-device \ |
| 41 | libtss2-tcti-device-dev \ |
| 42 | libtss2-tcti-device-staticdev \ |
| 43 | libtss2-tcti-mssim \ |
| 44 | libtss2-tcti-mssim-dev \ |
| 45 | libtss2-tcti-mssim-staticdev \ |
| 46 | libtss2 \ |
| 47 | libtss2-dev \ |
| 48 | libtss2-staticdev \ |
| 49 | " |
| 50 | |
| 51 | FILES_libtss2-tcti-device = "${libdir}/libtss2-tcti-device.so.*" |
| 52 | FILES_libtss2-tcti-device-dev = " \ |
| 53 | ${includedir}/tss2/tss2_tcti_device.h \ |
| 54 | ${libdir}/pkgconfig/tss2-tcti-device.pc \ |
| 55 | ${libdir}/libtss2-tcti-device.so" |
| 56 | FILES_libtss2-tcti-device-staticdev = "${libdir}/libtss2-tcti-device.*a" |
| 57 | |
| 58 | FILES_libtss2-tcti-mssim = "${libdir}/libtss2-tcti-mssim.so.*" |
| 59 | FILES_libtss2-tcti-mssim-dev = " \ |
| 60 | ${includedir}/tss2/tss2_tcti_mssim.h \ |
| 61 | ${libdir}/pkgconfig/tss2-tcti-mssim.pc \ |
| 62 | ${libdir}/libtss2-tcti-mssim.so" |
| 63 | FILES_libtss2-tcti-mssim-staticdev = "${libdir}/libtss2-tcti-mssim.*a" |
| 64 | |
| 65 | FILES_libtss2-mu = "${libdir}/libtss2-mu.so.*" |
| 66 | FILES_libtss2-mu-dev = " \ |
| 67 | ${includedir}/tss2/tss2_mu.h \ |
| 68 | ${libdir}/pkgconfig/tss2-mu.pc \ |
| 69 | ${libdir}/libtss2-mu.so" |
| 70 | FILES_libtss2-mu-staticdev = "${libdir}/libtss2-mu.*a" |
| 71 | |
| 72 | FILES_libtss2 = "${libdir}/libtss2*so.*" |
| 73 | FILES_libtss2-dev = " \ |
| 74 | ${includedir} \ |
| 75 | ${libdir}/pkgconfig \ |
| 76 | ${libdir}/libtss2*so" |
| 77 | FILES_libtss2-staticdev = "${libdir}/libtss*a" |
| 78 | |
Brad Bishop | 95dbbac | 2019-12-02 13:55:25 -0500 | [diff] [blame] | 79 | FILES_${PN} = "${libdir}/udev ${base_prefix}/lib/udev" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 80 | |
| 81 | RDEPENDS_libtss2 = "libgcrypt" |