Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require ${BPN}.inc |
| 2 | |
| 3 | SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \ |
| 4 | file://0001-meson.build-check-for-all-linux-host_os-combinations.patch \ |
| 5 | file://0002-meson.build-make-TLS-ELF-optional.patch \ |
| 6 | file://0003-Allow-enable-DRI-without-DRI-drivers.patch \ |
| 7 | file://0004-Revert-mesa-Enable-asm-unconditionally-now-that-gen_.patch \ |
| 8 | file://0005-vc4-use-intmax_t-for-formatted-output-of-timespec-me.patch \ |
| 9 | file://0001-meson-misdetects-64bit-atomics-on-mips-clang.patch \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI[md5sum] = "31ca59cd92c38cb8e1a58b62b01c3e08" |
| 13 | SRC_URI[sha256sum] = "aa54f1cb669550606aab8ceb475105d15aeb814fca5a778ce70d0fd10e98e86f" |
| 14 | |
| 15 | UPSTREAM_CHECK_GITTAGREGEX = "mesa-(?P<pver>\d+(\.\d+)+)" |
| 16 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | #because we cannot rely on the fact that all apps will use pkgconfig, |
| 18 | #make eglplatform.h independent of MESA_EGL_NO_X11_HEADER |
| 19 | do_install_append() { |
| 20 | if ${@bb.utils.contains('PACKAGECONFIG', 'egl', 'true', 'false', d)}; then |
| 21 | sed -i -e 's/^#elif defined(__unix__) && defined(EGL_NO_X11)$/#elif defined(__unix__) \&\& defined(EGL_NO_X11) || ${@bb.utils.contains('PACKAGECONFIG', 'x11', '0', '1', d)}/' ${D}${includedir}/EGL/eglplatform.h |
| 22 | fi |
| 23 | } |