Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" |
| 4 | SECTION = "bootloader" |
| 5 | DEPENDS = "mtd-utils" |
| 6 | |
| 7 | # This revision corresponds to the tag "v2015.07" |
| 8 | # We use the revision in order to avoid having to fetch it from the |
| 9 | # repo during parse |
| 10 | SRCREV = "33711bdd4a4dce942fb5ae85a68899a8357bdd94" |
| 11 | |
| 12 | PV = "v2015.07+git${SRCPV}" |
| 13 | |
| 14 | SRC_URI = "git://git.denx.de/u-boot.git;branch=master" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | INSANE_SKIP_${PN} = "already-stripped" |
| 19 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| 20 | EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| 21 | |
| 22 | inherit uboot-config |
| 23 | |
| 24 | do_compile () { |
| 25 | oe_runmake ${UBOOT_MACHINE} |
| 26 | oe_runmake env |
| 27 | } |
| 28 | |
| 29 | do_install () { |
| 30 | install -d ${D}${base_sbindir} |
| 31 | install -d ${D}${sysconfdir} |
| 32 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv |
| 33 | install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv |
| 34 | install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config |
| 35 | } |
| 36 | |
| 37 | do_install_class-cross () { |
| 38 | install -d ${D}${bindir_cross} |
| 39 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv |
| 40 | install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv |
| 41 | } |
| 42 | |
| 43 | SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross" |
| 44 | uboot_fw_utils_cross() { |
| 45 | sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} |
| 46 | } |
| 47 | |
| 48 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 49 | BBCLASSEXTEND = "cross" |