Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "A portable foreign function interface library" |
| 2 | DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \ |
| 3 | conventions. This allows a programmer to call any function specified by a call interface description at run \ |
| 4 | time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \ |
| 5 | interface that allows code written in one language to call code written in another language. The `libffi' \ |
| 6 | library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \ |
| 7 | A layer must exist above `libffi' that handles type conversions for values passed between the two languages." |
| 8 | |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3610bb17683a0089ed64055416b2ae1b" |
| 11 | |
| 12 | SRC_URI = "ftp://sourceware.org/pub/libffi/${BP}.tar.gz \ |
| 13 | file://fix-libffi.la-location.patch \ |
| 14 | file://0001-mips-Use-compiler-internal-define-for-linux.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "83b89587607e3eb65c70d361f13bab43" |
| 18 | SRC_URI[sha256sum] = "d06ebb8e1d9a22d19e38d63fdb83954253f39bedc5d46232a05645685722ca37" |
| 19 | |
| 20 | EXTRA_OECONF += "--disable-builddir" |
| 21 | |
| 22 | inherit autotools texinfo |
| 23 | |
| 24 | FILES_${PN}-dev += "${libdir}/libffi-${PV}" |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |