Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Perl module for using and building Perl SAX2 XML processors" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://search.cpan.org/dist/XML-SAX/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | DESCRIPTION = "XML::SAX consists of several framework classes for using and \ |
| 4 | building Perl SAX2 XML parsers, filters, and drivers. It is designed \ |
| 5 | around the need to be able to "plug in" different SAX parsers to an \ |
| 6 | application without requiring programmer intervention. Those of you \ |
| 7 | familiar with the DBI will be right at home. Some of the designs \ |
| 8 | come from the Java JAXP specification (SAX part), only without the \ |
| 9 | javaness." |
| 10 | |
| 11 | SECTION = "libs" |
| 12 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 13 | DEPENDS += "libxml-namespacesupport-perl-native" |
| 14 | RDEPENDS_${PN} += "libxml-namespacesupport-perl libxml-sax-base-perl perl-module-file-temp" |
| 15 | PR = "r2" |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=65c4cd8f39c24c7135ed70dacbcb09e3" |
| 18 | |
| 19 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GR/GRANTM/XML-SAX-${PV}.tar.gz" |
| 20 | |
| 21 | SRC_URI[md5sum] = "290f5375ae87fdebfdb5bc3854019f24" |
| 22 | SRC_URI[sha256sum] = "32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6f5ad84" |
| 23 | |
| 24 | S = "${WORKDIR}/XML-SAX-${PV}" |
| 25 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | inherit cpan ptest-perl |
| 27 | |
| 28 | do_install_ptest() { |
| 29 | cp -r ${B}/testfiles ${D}${PTEST_PATH} |
| 30 | chown -R root:root ${D}${PTEST_PATH}/testfiles |
| 31 | } |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | |
| 33 | BBCLASSEXTEND = "native" |