Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "A UPnP AV media server and renderer" |
| 2 | DESCRIPTION = "Rygel is a home media solution (UPnP AV MediaServer) that \ |
| 3 | allow you to easily share audio, video and pictures to other devices. \ |
| 4 | Additionally, media player software may use Rygel to become a MediaRenderer \ |
| 5 | that may be controlled remotely by a UPnP or DLNA Controller." |
| 6 | HOMEPAGE = "http://live.gnome.org/Rygel" |
| 7 | |
| 8 | LICENSE = "LGPL-2.1" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 10 | |
| 11 | DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native" |
| 12 | RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info" |
| 13 | RRECOMMENDS_${PN} = "rygel-plugin-media-export" |
| 14 | |
| 15 | GNOME_COMPRESS_TYPE = "xz" |
| 16 | SRC_URI[archive.md5sum] = "f897167ad82e2e741582f2c393a76843" |
| 17 | SRC_URI[archive.sha256sum] = "dfd3d885da3ac383ba0cfbf119995f4a0c2bca2cc8f8cfcd3df10cfec8f35cd7" |
| 18 | |
| 19 | inherit gnomebase vala gobject-introspection gettext systemd |
| 20 | |
| 21 | EXTRA_OECONF = "--disable-tracker-plugin --with-media-engine=gstreamer" |
| 22 | |
| 23 | PACKAGECONFIG ?= "external mpris ruih media-export gst-launch" |
| 24 | |
| 25 | PACKAGECONFIG_append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}" |
| 26 | |
| 27 | PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin" |
| 28 | PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin" |
| 29 | PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin" |
| 30 | PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin" |
| 31 | PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin" |
| 32 | PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3" |
| 33 | PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin" |
| 34 | |
| 35 | LIBV = "2.6" |
| 36 | |
| 37 | do_install_append() { |
| 38 | # Remove .la files for loadable modules |
| 39 | rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la |
| 40 | rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la |
| 41 | if [ -e ${D}${libdir}/systemd/user/rygel.service ]; then |
| 42 | mkdir -p ${D}${systemd_unitdir}/system |
| 43 | mv ${D}${libdir}/systemd/user/rygel.service ${D}${systemd_unitdir}/system |
| 44 | rmdir ${D}${libdir}/systemd/user ${D}${libdir}/systemd |
| 45 | fi |
| 46 | } |
| 47 | |
| 48 | FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons" |
| 49 | FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug" |
| 50 | |
| 51 | PACKAGES += "${PN}-meta" |
| 52 | ALLOW_EMPTY_${PN}-meta = "1" |
| 53 | |
| 54 | PACKAGES_DYNAMIC = "${PN}-plugin-*" |
| 55 | |
| 56 | SYSTEMD_SERVICE_${PN} = "rygel.service" |
| 57 | |
| 58 | python populate_packages_prepend () { |
| 59 | rygel_libdir = d.expand('${libdir}/rygel-${LIBV}') |
| 60 | postinst = d.getVar('plugin_postinst') |
| 61 | pkgs = [] |
| 62 | |
| 63 | pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) |
| 64 | pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}')) |
| 65 | |
| 66 | metapkg = d.getVar('PN') + '-meta' |
| 67 | d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs)) |
| 68 | } |