Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame^] | 1 | SUMMARY = "msmtp is an SMTP client" |
| 2 | DESCRIPTION = "A sendmail replacement for use in MTAs like mutt" |
| 3 | HOMEPAGE = "https://marlam.de/msmtp/" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | LICENSE = "GPLv3" |
| 7 | DEPENDS = "zlib gnutls" |
| 8 | |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 10 | |
| 11 | UPSTREAM_CHECK_URI = "https://marlam.de/msmtp/download/" |
| 12 | |
| 13 | SRC_URI = "https://marlam.de/${BPN}/releases/${BP}.tar.xz" |
| 14 | SRC_URI[md5sum] = "abfabb92f0461137f3c09cd16d98fc9b" |
| 15 | SRC_URI[sha256sum] = "e5dd7fe95bc8e2f5eea3e4894ec9628252f30bd700a7fd1a568b10efa91129f7" |
| 16 | |
| 17 | inherit gettext autotools update-alternatives pkgconfig |
| 18 | |
| 19 | EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn" |
| 20 | |
| 21 | ALTERNATIVE_${PN} = "sendmail" |
| 22 | ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp" |
| 23 | ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail" |
| 24 | ALTERNATIVE_PRIORITY = "100" |
| 25 | |
| 26 | pkg_postinst_${PN}_linuxstdbase () { |
| 27 | # /usr/lib/sendmial is required by LSB core test |
| 28 | [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/ |
| 29 | } |