Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Extensible memoizing collections and decorators" |
| 2 | HOMEPAGE = "https://github.com/tkem/cachetools" |
| 3 | DESCRIPTION = "This module provides various memoizing \ |
| 4 | collections and decorators, including variants of the \ |
| 5 | Python 3 Standard Library @lru_cache function decorator." |
| 6 | SECTION = "devel/python" |
| 7 | |
| 8 | LICENSE = "MIT" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d1e1bf0ccb26126a230c51f997ce362" |
| 10 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 11 | inherit pypi setuptools3 ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 17 | RDEPENDS_${PN} += " \ |
| 18 | ${PYTHON_PN}-math \ |
| 19 | " |
| 20 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 21 | RDEPENDS_${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 30 | SRC_URI[sha256sum] = "f469e29e7aa4cff64d8de4aad95ce76de8ea1125a16c68e0d93f65c3c3dc92e9" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |