blob: 79a7ac1bf9bc520624455b8701e455ba122f2a4b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Provides cryptographic recipes and primitives to python developers"
2HOMEPAGE = "https://cryptography.io/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0 | BSD"
Andrew Geisslereef63862021-01-29 15:58:13 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba"
Brad Bishop316dfdd2018-06-25 12:45:53 -04006
7LDSHARED += "-pthread"
8
Andrew Geisslereef63862021-01-29 15:58:13 -06009SRC_URI[sha256sum] = "7e177e4bea2de937a584b13645cab32f25e3d96fc0bc4a4cf99c27dc77682be6"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Brad Bishop316dfdd2018-06-25 12:45:53 -040011SRC_URI += " \
12 file://run-ptest \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013 file://h-test.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040014"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16inherit pypi setuptools3
17
18DEPENDS += " \
19 ${PYTHON_PN}-cffi \
20 ${PYTHON_PN}-cffi-native \
21 ${PYTHON_PN}-asn1crypto \
22 ${PYTHON_PN}-six \
23"
24
25RDEPENDS_${PN} += " \
26 ${PYTHON_PN}-cffi \
27 ${PYTHON_PN}-idna \
28 ${PYTHON_PN}-asn1crypto \
29 ${PYTHON_PN}-setuptools \
30 ${PYTHON_PN}-six \
31"
32
33RDEPENDS_${PN}_class-target += " \
34 ${PYTHON_PN}-cffi \
35 ${PYTHON_PN}-idna \
36 ${PYTHON_PN}-numbers \
37 ${PYTHON_PN}-asn1crypto \
38 ${PYTHON_PN}-setuptools \
39 ${PYTHON_PN}-six \
40 ${PYTHON_PN}-threading \
41"
42
43RDEPENDS_${PN}-ptest += " \
44 ${PN} \
45 ${PYTHON_PN}-cryptography-vectors \
46 ${PYTHON_PN}-iso8601 \
47 ${PYTHON_PN}-pretend \
48 ${PYTHON_PN}-pytest \
49 ${PYTHON_PN}-pytz \
50"
51
52inherit ptest
53
54do_install_ptest() {
55 install -d ${D}${PTEST_PATH}/tests
56 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
57 install -d ${D}${PTEST_PATH}/tests/hazmat
58 cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
59}
60
61FILES_${PN}-dbg += " \
62 ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
63"
64
65BBCLASSEXTEND = "native nativesdk"