blob: 9507f60d767fd62e91c99e3fa65f3759041e588a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "CSS selector library for python-beautifulsoup4"
2HOMEPAGE = "https://github.com/facelessuser/soupsieve"
3
4LICENSE = "MIT"
Andrew Geissler97771a32021-03-05 15:23:11 -06005LIC_FILES_CHKSUM = "file://LICENSE.md;md5=33c3a77def9b3ad83e01c65bdcc1af67"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geissler97771a32021-03-05 15:23:11 -06007SRC_URI[sha256sum] = "407fa1e8eb3458d1b5614df51d9651a1180ea5fedf07feb46e45d7e25e6d6cdd"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
Andrew Geissler748a4832020-07-24 16:24:21 -05009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS_${PN}-ptest += " \
16 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-beautifulsoup4 \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25BBCLASSEXTEND = "native nativesdk"