blob: 34162d3cc510a832119a66196b7fa4c796a10067 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Backup, restore, import, and export panel layouts"
2SECTION = "x11/application"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
Andrew Geissler72956ed2021-01-08 16:11:14 -06006inherit python3native gettext gtk-icon-cache features_check
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8REQUIRED_DISTRO_FEATURES = "x11"
9
10DEPENDS += "intltool-native"
11
12SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2 \
13 file://not-create-link-to-locale.patch \
Andrew Geisslereef63862021-01-29 15:58:13 -060014 file://0001-Makefile.in.in-remove-bashisms.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 "
Andrew Geissler72956ed2021-01-08 16:11:14 -060016SRC_URI[sha256sum] = "246e459d2d2f3f524968440ed7fddb2a891567ebc05f10a800f7f5821b3452a7"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18do_configure() {
19 # special configure - no autotools...
20 ./configure --prefix=${prefix}
21}
22
23do_install() {
24 oe_runmake 'DESTDIR=${D}' install
25 sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
26}
27
28FILES_${PN} += "${datadir}/metainfo"
29
30RDEPENDS_${PN} += "python3-pygobject python3-pexpect"