Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Backup, restore, import, and export panel layouts" |
| 2 | SECTION = "x11/application" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 6 | inherit python3native gettext gtk-icon-cache features_check |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | DEPENDS += "intltool-native" |
| 11 | |
| 12 | SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2 \ |
| 13 | file://not-create-link-to-locale.patch \ |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 14 | file://0001-Makefile.in.in-remove-bashisms.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | " |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "246e459d2d2f3f524968440ed7fddb2a891567ebc05f10a800f7f5821b3452a7" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | do_configure() { |
| 19 | # special configure - no autotools... |
| 20 | ./configure --prefix=${prefix} |
| 21 | } |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake 'DESTDIR=${D}' install |
| 25 | sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles |
| 26 | } |
| 27 | |
| 28 | FILES_${PN} += "${datadir}/metainfo" |
| 29 | |
| 30 | RDEPENDS_${PN} += "python3-pygobject python3-pexpect" |