Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Apache Portable Runtime (APR) library" |
| 2 | HOMEPAGE = "http://apr.apache.org/" |
| 3 | SECTION = "libs" |
| 4 | DEPENDS = "util-linux" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \ |
Brad Bishop | c4ea075 | 2018-11-15 14:30:15 -0800 | [diff] [blame^] | 8 | file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | |
| 10 | BBCLASSEXTEND = "native nativesdk" |
| 11 | |
| 12 | SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \ |
| 13 | file://run-ptest \ |
| 14 | file://0001-build-buildcheck.sh-improve-libtool-detection.patch \ |
| 15 | file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \ |
| 16 | file://0003-Makefile.in-configure.in-support-cross-compiling.patch \ |
| 17 | file://0004-Fix-packet-discards-HTTP-redirect.patch \ |
| 18 | file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \ |
| 19 | file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \ |
| 20 | file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \ |
| 21 | " |
| 22 | |
| 23 | SRC_URI[md5sum] = "12f2a349483ad6f12db49ba01fbfdbfa" |
| 24 | SRC_URI[sha256sum] = "131f06d16d7aabd097fa992a33eec2b6af3962f93e6d570a9bd4d85e95993172" |
| 25 | |
| 26 | inherit autotools-brokensep lib_package binconfig multilib_header ptest |
| 27 | |
| 28 | OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'" |
| 29 | |
| 30 | # Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928 |
| 31 | CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes" |
| 32 | |
| 33 | # Also suppress trying to use sctp. |
| 34 | # |
| 35 | CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no" |
| 36 | |
| 37 | CACHED_CONFIGUREVARS += "ac_cv_sizeof_struct_iovec=yes" |
| 38 | CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes" |
| 39 | |
| 40 | # Otherwise libtool fails to compile apr-utils |
| 41 | # x86_64-linux-libtool: compile: unable to infer tagged configuration |
| 42 | # x86_64-linux-libtool: error: specify a tag with '--tag' |
| 43 | CCACHE = "" |
| 44 | |
| 45 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 46 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 47 | |
| 48 | do_configure_prepend() { |
| 49 | # Avoid absolute paths for grep since it causes failures |
| 50 | # when using sstate between different hosts with different |
| 51 | # install paths for grep. |
| 52 | export GREP="grep" |
| 53 | |
| 54 | cd ${S} |
| 55 | libtool='${HOST_SYS}-libtool' ./buildconf |
| 56 | } |
| 57 | |
| 58 | FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*" |
| 59 | RDEPENDS_${PN}-dev += "bash" |
| 60 | |
| 61 | #for some reason, build/libtool.m4 handled by buildconf still be overwritten |
| 62 | #when autoconf, so handle it again. |
| 63 | do_configure_append() { |
| 64 | sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4 |
| 65 | sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk |
| 66 | } |
| 67 | |
| 68 | do_install_append() { |
| 69 | oe_multilib_header apr.h |
| 70 | install -d ${D}${datadir}/apr |
| 71 | } |
| 72 | |
| 73 | do_install_append_class-target() { |
| 74 | sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \ |
| 75 | -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk |
| 76 | sed -i -e 's,${STAGING_DIR_HOST},,g' \ |
| 77 | -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \ |
| 78 | -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config |
| 79 | } |
| 80 | |
| 81 | SSTATE_SCAN_FILES += "apr_rules.mk libtool" |
| 82 | |
| 83 | SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess" |
| 84 | |
| 85 | apr_sysroot_preprocess () { |
| 86 | d=${SYSROOT_DESTDIR}${datadir}/apr |
| 87 | install -d $d/ |
| 88 | cp ${S}/build/apr_rules.mk $d/ |
| 89 | sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk |
| 90 | sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk |
| 91 | sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk |
| 92 | sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk |
| 93 | cp ${S}/build/mkdir.sh $d/ |
| 94 | cp ${S}/build/make_exports.awk $d/ |
| 95 | cp ${S}/build/make_var_export.awk $d/ |
| 96 | cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool |
| 97 | } |
| 98 | |
| 99 | do_compile_ptest() { |
| 100 | cd ${S}/test |
| 101 | oe_runmake |
| 102 | } |
| 103 | |
| 104 | do_install_ptest() { |
| 105 | t=${D}${PTEST_PATH}/test |
| 106 | mkdir -p $t/.libs |
| 107 | cp -r ${S}/test/data $t/ |
| 108 | cp -r ${S}/test/.libs/*.so $t/.libs/ |
| 109 | cp ${S}/test/proc_child $t/ |
| 110 | cp ${S}/test/readchild $t/ |
| 111 | cp ${S}/test/sockchild $t/ |
| 112 | cp ${S}/test/sockperf $t/ |
| 113 | cp ${S}/test/testall $t/ |
| 114 | cp ${S}/test/tryread $t/ |
| 115 | } |
| 116 | |
| 117 | export CONFIG_SHELL="/bin/bash" |