Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Multimedia processing server for Linux" |
| 2 | DESCRIPTION = "Linux server for handling and routing audio and video streams between applications and multimedia I/O devices" |
| 3 | HOMEPAGE = "https://pipewire.org/" |
| 4 | BUGTRACKER = "https://gitlab.freedesktop.org/pipewire/pipewire/issues" |
| 5 | AUTHOR = "Wim Taymans <wtaymans@redhat.com>" |
| 6 | SECTION = "multimedia" |
| 7 | |
| 8 | LICENSE = "MIT & LGPL-2.1-or-later & GPL-2.0-only" |
| 9 | LIC_FILES_CHKSUM = " \ |
| 10 | file://LICENSE;md5=2158739e172e58dc9ab1bdd2d6ec9c72 \ |
| 11 | file://COPYING;md5=97be96ca4fab23e9657ffa590b931c1a \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS = "dbus ncurses" |
| 15 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame^] | 16 | SRCREV = "bba452695eb673461c5cf626eec57728991eadf7" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame^] | 21 | inherit gsettings meson pkgconfig systemd gettext useradd |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 22 | |
| 23 | USERADD_PACKAGES = "${PN}" |
| 24 | |
| 25 | GROUPADD_PARAM:${PN} = "--system pipewire" |
| 26 | |
| 27 | USERADD_PARAM:${PN} = "--system --home / --no-create-home \ |
| 28 | --comment 'PipeWire multimedia daemon' \ |
| 29 | --gid pipewire --groups audio,video \ |
| 30 | pipewire" |
| 31 | |
| 32 | SYSTEMD_PACKAGES = "${PN}" |
| 33 | |
| 34 | # For "EVL", look up https://evlproject.org/ . It involves |
| 35 | # a specially prepared kernel, and is currently unavailable |
| 36 | # in Yocto. |
| 37 | # |
| 38 | # Vulkan support is currently (as of version 0.3.44) not functional. |
| 39 | # |
| 40 | # manpage generation requires xmltoman, which is not available. |
| 41 | # |
| 42 | # The session-managers list specifies which session managers Meson |
| 43 | # shall download (via git clone) and build as subprojects. In OE, |
| 44 | # this is not how a session manager should be built. Instead, they |
| 45 | # should be integrated as separate OE recipes. To prevent PipeWire |
| 46 | # from using this Meson feature, set an empty list. |
| 47 | # This does not disable support or the need for session managers, |
| 48 | # it just prevents this subproject feature. |
| 49 | # |
| 50 | # AptX and LDAC are not available in OE. Currently, neither |
| 51 | # are lv2 and ROC. |
| 52 | # |
| 53 | # The RTKit module is deprecated in favor of the newer RT module. |
| 54 | # It still exists for legacy setups that still include it in |
| 55 | # their PipeWire configuration files. |
| 56 | EXTRA_OEMESON += " \ |
| 57 | -Devl=disabled \ |
| 58 | -Dtests=disabled \ |
| 59 | -Dudevrulesdir=${nonarch_base_libdir}/udev/rules.d/ \ |
| 60 | -Dsystemd-system-unit-dir=${systemd_system_unitdir} \ |
| 61 | -Dsystemd-user-unit-dir=${systemd_user_unitdir} \ |
| 62 | -Dman=disabled \ |
| 63 | -Dsession-managers='[]' \ |
| 64 | -Dlv2=disabled \ |
| 65 | -Droc=disabled \ |
| 66 | -Dbluez5-codec-aptx=disabled \ |
| 67 | -Dbluez5-codec-ldac=disabled \ |
| 68 | -Dlegacy-rtkit=false \ |
| 69 | " |
| 70 | |
| 71 | # spa alsa plugin code uses typedef redefinition, which is officially a C11 feature. |
| 72 | # Pipewire builds with 'c_std=gnu99' by default. Recent versions of gcc don't issue this warning in gnu99 |
| 73 | # mode but it looks like clang still does |
| 74 | CFLAGS:append = " -Wno-typedef-redefinition" |
| 75 | |
| 76 | # According to wireplumber documentation only one session manager should be installed at a time |
| 77 | # Possible options are media-session, which has fewer dependencies but is very simple, |
| 78 | # or wireplumber, which is more powerful. |
| 79 | PIPEWIRE_SESSION_MANAGER ??= "wireplumber" |
| 80 | |
| 81 | FFMPEG_AVAILABLE = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'ffmpeg', '', d)}" |
| 82 | BLUETOOTH_AAC = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'bluez-aac', '', d)}" |
| 83 | |
| 84 | PACKAGECONFIG:class-target ??= " \ |
| 85 | ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \ |
| 86 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez bluez-opus ${BLUETOOTH_AAC}', '', d)} \ |
| 87 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service systemd-user-service', '', d)} \ |
| 88 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio gtk', 'gsettings', '', d)} \ |
| 89 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa vulkan pulseaudio', d)} \ |
| 90 | ${PIPEWIRE_SESSION_MANAGER} \ |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame^] | 91 | ${FFMPEG_AVAILABLE} avahi flatpak gstreamer gsettings jack libusb pw-cat raop sndfile v4l2 udev volume webrtc-echo-cancelling libcamera \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 92 | " |
| 93 | |
| 94 | # "jack" and "pipewire-jack" packageconfigs cannot be both enabled, |
| 95 | # since "jack" imports libjack, and "pipewire-jack" generates |
| 96 | # libjack.so* files, thus colliding with the libpack package. This |
| 97 | # is why these two are marked in their respective packageconfigs |
| 98 | # as being in conflict. |
| 99 | PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev,,pipewire-alsa pipewire-alsa-card-profile" |
| 100 | PACKAGECONFIG[avahi] = "-Davahi=enabled,-Davahi=disabled,avahi" |
| 101 | PACKAGECONFIG[bluez] = "-Dbluez5=enabled,-Dbluez5=disabled,bluez5 sbc" |
| 102 | PACKAGECONFIG[bluez-aac] = "-Dbluez5-codec-aac=enabled,-Dbluez5-codec-aac=disabled,fdk-aac" |
| 103 | PACKAGECONFIG[bluez-opus] = "-Dbluez5-codec-opus=enabled,-Dbluez5-codec-opus=disabled,libopus" |
| 104 | PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native graphviz-native" |
| 105 | PACKAGECONFIG[ffmpeg] = "-Dffmpeg=enabled,-Dffmpeg=disabled,ffmpeg" |
| 106 | PACKAGECONFIG[flatpak] = "-Dflatpak=enabled,-Dflatpak=disabled,glib-2.0" |
| 107 | PACKAGECONFIG[gsettings] = "-Dgsettings=enabled,-Dgsettings=disabled,glib-2.0" |
| 108 | PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base,,gstreamer1.0-pipewire" |
| 109 | PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack,,,pipewire-jack" |
| 110 | PACKAGECONFIG[libcamera] = "-Dlibcamera=enabled,-Dlibcamera=disabled,libcamera libdrm" |
| 111 | PACKAGECONFIG[libcanberra] = "-Dlibcanberra=enabled,-Dlibcanberra=disabled,libcanberra" |
| 112 | PACKAGECONFIG[libusb] = "-Dlibusb=enabled,-Dlibusb=disabled,libusb" |
| 113 | PACKAGECONFIG[media-session] = ",,,pipewire-media-session,,wireplumber" |
| 114 | PACKAGECONFIG[pulseaudio] = "-Dlibpulse=enabled,-Dlibpulse=disabled,pulseaudio,,pipewire-pulse" |
| 115 | PACKAGECONFIG[pipewire-alsa] = "-Dpipewire-alsa=enabled,-Dpipewire-alsa=disabled,alsa-lib" |
| 116 | PACKAGECONFIG[pipewire-jack] = "-Dpipewire-jack=enabled -Dlibjack-path=${libdir}/${PW_MODULE_SUBDIR}/jack,-Dpipewire-jack=disabled,jack,,pipewire-jack,jack" |
| 117 | PACKAGECONFIG[pw-cat] = "-Dpw-cat=enabled,-Dpw-cat=disabled" |
| 118 | PACKAGECONFIG[raop] = "-Draop=enabled,-Draop=disabled,openssl" |
| 119 | PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,libsdl2" |
| 120 | PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1" |
| 121 | PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd" |
| 122 | PACKAGECONFIG[systemd-system-service] = "-Dsystemd-system-service=enabled,-Dsystemd-system-service=disabled,systemd" |
| 123 | # "systemd-user-service" packageconfig will only install service |
| 124 | # files to rootfs but not enable them as systemd.bbclass |
| 125 | # currently lacks the feature of enabling user services. |
| 126 | PACKAGECONFIG[systemd-user-service] = "-Dsystemd-user-service=enabled,-Dsystemd-user-service=disabled,systemd" |
| 127 | # pw-cat needs sndfile packageconfig to be enabled |
| 128 | PACKAGECONFIG[udev] = "-Dudev=enabled,-Dudev=disabled,udev" |
| 129 | PACKAGECONFIG[v4l2] = "-Dv4l2=enabled,-Dv4l2=disabled,udev" |
| 130 | PACKAGECONFIG[volume] = "-Dvolume=enabled,-Dvolume=disabled" |
| 131 | PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-headers vulkan-loader" |
| 132 | PACKAGECONFIG[webrtc-echo-cancelling] = "-Decho-cancel-webrtc=enabled,-Decho-cancel-webrtc=disabled,webrtc-audio-processing" |
| 133 | PACKAGECONFIG[wireplumber] = ",,,wireplumber,,media-session" |
| 134 | |
| 135 | PACKAGESPLITFUNCS:prepend = " split_dynamic_packages " |
| 136 | PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends " |
| 137 | |
| 138 | SPA_SUBDIR = "spa-0.2" |
| 139 | PW_MODULE_SUBDIR = "pipewire-0.3" |
| 140 | |
| 141 | remove_unused_installed_files() { |
| 142 | # jack.conf is used by pipewire-jack (not the JACK SPA plugin). |
| 143 | # Remove it if pipewire-jack is not built to avoid creating the |
| 144 | # pipewire-jack package. |
| 145 | if ${@bb.utils.contains('PACKAGECONFIG', 'pipewire-jack', 'false', 'true', d)}; then |
| 146 | rm -f "${D}${datadir}/pipewire/jack.conf" |
| 147 | fi |
| 148 | |
| 149 | # minimal.conf is an example of how to minimally configure the |
| 150 | # daemon and is not meant to be used for production. |
| 151 | rm -f "${D}${datadir}/pipewire/minimal.conf" |
| 152 | } |
| 153 | |
| 154 | do_install[postfuncs] += "remove_unused_installed_files" |
| 155 | |
| 156 | python split_dynamic_packages () { |
| 157 | # Create packages for each SPA plugin. These plugins are located |
| 158 | # in individual subdirectories, so a recursive search is needed. |
| 159 | spa_libdir = d.expand('${libdir}/${SPA_SUBDIR}') |
| 160 | do_split_packages(d, spa_libdir, r'^libspa-(.*)\.so$', d.expand('${PN}-spa-plugins-%s'), 'PipeWire SPA plugin for %s', extra_depends='', recursive=True) |
| 161 | |
| 162 | # Create packages for each PipeWire module. |
| 163 | pw_module_libdir = d.expand('${libdir}/${PW_MODULE_SUBDIR}') |
| 164 | do_split_packages(d, pw_module_libdir, r'^libpipewire-module-(.*)\.so$', d.expand('${PN}-modules-%s'), 'PipeWire %s module', extra_depends='', recursive=False) |
| 165 | } |
| 166 | |
| 167 | python set_dynamic_metapkg_rdepends () { |
| 168 | import os |
| 169 | import oe.utils |
| 170 | |
| 171 | # Go through all generated SPA plugin and PipeWire module packages |
| 172 | # (excluding the main package and the -meta package itself) and |
| 173 | # add them to the -meta package as RDEPENDS. |
| 174 | |
| 175 | base_pn = d.getVar('PN') |
| 176 | |
| 177 | spa_pn = base_pn + '-spa-plugins' |
| 178 | spa_metapkg = spa_pn + '-meta' |
| 179 | |
| 180 | pw_module_pn = base_pn + '-modules' |
| 181 | pw_module_metapkg = pw_module_pn + '-meta' |
| 182 | |
| 183 | d.setVar('ALLOW_EMPTY:' + spa_metapkg, "1") |
| 184 | d.setVar('FILES:' + spa_metapkg, "") |
| 185 | |
| 186 | d.setVar('ALLOW_EMPTY:' + pw_module_metapkg, "1") |
| 187 | d.setVar('FILES:' + pw_module_metapkg, "") |
| 188 | |
| 189 | blacklist = [ spa_pn, spa_metapkg, pw_module_pn, pw_module_metapkg ] |
| 190 | spa_metapkg_rdepends = [] |
| 191 | pw_module_metapkg_rdepends = [] |
| 192 | pkgdest = d.getVar('PKGDEST') |
| 193 | |
| 194 | for pkg in oe.utils.packages_filter_out_system(d): |
| 195 | if pkg in blacklist: |
| 196 | continue |
| 197 | |
| 198 | is_spa_pkg = pkg.startswith(spa_pn) |
| 199 | is_pw_module_pkg = pkg.startswith(pw_module_pn) |
| 200 | if not is_spa_pkg and not is_pw_module_pkg: |
| 201 | continue |
| 202 | |
| 203 | if pkg in spa_metapkg_rdepends or pkg in pw_module_metapkg_rdepends: |
| 204 | continue |
| 205 | |
| 206 | # See if the package is empty by looking at the contents of its |
| 207 | # PKGDEST subdirectory. If this subdirectory is empty, then then |
| 208 | # package is empty as well. Empty packages do not get added to |
| 209 | # the meta package's RDEPENDS. |
| 210 | pkgdir = os.path.join(pkgdest, pkg) |
| 211 | if os.path.exists(pkgdir): |
| 212 | dir_contents = os.listdir(pkgdir) or [] |
| 213 | else: |
| 214 | dir_contents = [] |
| 215 | is_empty = len(dir_contents) == 0 |
| 216 | if not is_empty: |
| 217 | if is_spa_pkg: |
| 218 | spa_metapkg_rdepends.append(pkg) |
| 219 | if is_pw_module_pkg: |
| 220 | pw_module_metapkg_rdepends.append(pkg) |
| 221 | |
| 222 | d.setVar('RDEPENDS:' + spa_metapkg, ' '.join(spa_metapkg_rdepends)) |
| 223 | d.setVar('DESCRIPTION:' + spa_metapkg, spa_pn + ' meta package') |
| 224 | |
| 225 | d.setVar('RDEPENDS:' + pw_module_metapkg, ' '.join(pw_module_metapkg_rdepends)) |
| 226 | d.setVar('DESCRIPTION:' + pw_module_metapkg, pw_module_pn + ' meta package') |
| 227 | } |
| 228 | |
| 229 | PACKAGES =+ "\ |
| 230 | libpipewire \ |
| 231 | ${PN}-tools \ |
| 232 | ${PN}-pulse \ |
| 233 | ${PN}-alsa \ |
| 234 | ${PN}-jack \ |
| 235 | ${PN}-spa-plugins \ |
| 236 | ${PN}-spa-plugins-meta \ |
| 237 | ${PN}-spa-tools \ |
| 238 | ${PN}-modules \ |
| 239 | ${PN}-modules-meta \ |
| 240 | ${PN}-alsa-card-profile \ |
| 241 | ${PN}-v4l2 \ |
| 242 | gstreamer1.0-pipewire \ |
| 243 | " |
| 244 | |
| 245 | PACKAGES_DYNAMIC = "^${PN}-spa-plugins.* ^${PN}-modules.*" |
| 246 | |
| 247 | SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd-system-service', 'pipewire.service', '', d)}" |
| 248 | CONFFILES:${PN} += "${datadir}/pipewire/pipewire.conf" |
| 249 | FILES:${PN} = " \ |
| 250 | ${datadir}/pipewire \ |
| 251 | ${systemd_system_unitdir}/pipewire* \ |
| 252 | ${systemd_user_unitdir} \ |
| 253 | ${bindir}/pipewire \ |
| 254 | ${bindir}/pipewire-avb \ |
| 255 | " |
| 256 | |
| 257 | RRECOMMENDS:${PN}:class-target += " \ |
| 258 | pipewire-modules-meta \ |
| 259 | pipewire-spa-plugins-meta \ |
| 260 | " |
| 261 | |
| 262 | FILES:${PN}-dev += " \ |
| 263 | ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so \ |
| 264 | " |
| 265 | |
| 266 | CONFFILES:libpipewire += "${datadir}/pipewire/client.conf" |
| 267 | FILES:libpipewire = " \ |
| 268 | ${datadir}/pipewire/client.conf \ |
| 269 | ${libdir}/libpipewire-*.so.* \ |
| 270 | " |
| 271 | # Add the bare minimum modules and plugins required to be able |
| 272 | # to use libpipewire. Without these, it is essentially unusable. |
| 273 | RDEPENDS:libpipewire += " \ |
| 274 | ${PN}-modules-client-node \ |
| 275 | ${PN}-modules-protocol-native \ |
| 276 | ${PN}-spa-plugins-support \ |
| 277 | " |
| 278 | |
| 279 | FILES:${PN}-tools = " \ |
| 280 | ${bindir}/pw-cat \ |
| 281 | ${bindir}/pw-cli \ |
| 282 | ${bindir}/pw-dot \ |
| 283 | ${bindir}/pw-dsdplay \ |
| 284 | ${bindir}/pw-dump \ |
| 285 | ${bindir}/pw-link \ |
| 286 | ${bindir}/pw-loopback \ |
| 287 | ${bindir}/pw-metadata \ |
| 288 | ${bindir}/pw-mididump \ |
| 289 | ${bindir}/pw-midiplay \ |
| 290 | ${bindir}/pw-midirecord \ |
| 291 | ${bindir}/pw-mon \ |
| 292 | ${bindir}/pw-play \ |
| 293 | ${bindir}/pw-profiler \ |
| 294 | ${bindir}/pw-record \ |
| 295 | ${bindir}/pw-reserve \ |
| 296 | ${bindir}/pw-top \ |
| 297 | " |
| 298 | |
| 299 | # This is a shim daemon that is intended to be used as a |
| 300 | # drop-in PulseAudio replacement, providing a pulseaudio-compatible |
| 301 | # socket that can be used by applications that use libpulse. |
| 302 | CONFFILES:${PN}-pulse += "${datadir}/pipewire/pipewire-pulse.conf" |
| 303 | FILES:${PN}-pulse = " \ |
| 304 | ${datadir}/pipewire/pipewire-pulse.conf \ |
| 305 | ${systemd_system_unitdir}/pipewire-pulse.* \ |
| 306 | ${systemd_user_unitdir}/pipewire-pulse.* \ |
| 307 | ${bindir}/pipewire-pulse \ |
| 308 | " |
| 309 | RDEPENDS:${PN}-pulse += " \ |
| 310 | ${PN}-modules-protocol-pulse \ |
| 311 | " |
| 312 | |
| 313 | # ALSA plugin to redirect audio to pipewire. |
| 314 | FILES:${PN}-alsa = "\ |
| 315 | ${libdir}/alsa-lib/* \ |
| 316 | ${datadir}/alsa/alsa.conf.d/* \ |
| 317 | " |
| 318 | |
| 319 | # JACK drop-in libraries to redirect audio to pipewire. |
| 320 | CONFFILES:${PN}-jack = "${datadir}/pipewire/jack.conf" |
| 321 | FILES:${PN}-jack = "\ |
| 322 | ${bindir}/pw-jack \ |
| 323 | ${datadir}/pipewire/jack.conf \ |
| 324 | ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so.* \ |
| 325 | " |
| 326 | |
| 327 | # Dynamic SPA plugin packages (see set_dynamic_metapkg_rdepends). |
| 328 | FILES:${PN}-spa-plugins = "" |
| 329 | RRECOMMENDS:${PN}-spa-plugins += "${PN}-spa-plugins-meta" |
| 330 | |
| 331 | FILES:${PN}-spa-plugins-bluez5 += " \ |
| 332 | ${datadir}/${SPA_SUBDIR}/bluez5/* \ |
| 333 | " |
| 334 | |
| 335 | FILES:${PN}-spa-tools = " \ |
| 336 | ${bindir}/spa-* \ |
| 337 | " |
| 338 | |
| 339 | # Dynamic PipeWire module packages (see set_dynamic_metapkg_rdepends). |
| 340 | FILES:${PN}-modules = "" |
| 341 | RRECOMMENDS:${PN}-modules += "${PN}-modules-meta" |
| 342 | |
| 343 | CONFFILES:${PN}-modules-rt = "${datadir}/pipewire/client-rt.conf" |
| 344 | FILES:${PN}-modules-rt += " \ |
| 345 | ${datadir}/pipewire/client-rt.conf \ |
| 346 | " |
| 347 | |
| 348 | CONFFILES:${PN}-modules-filter-chain = "${datadir}/pipewire/filter-chain/*" |
| 349 | FILES:${PN}-modules-filter-chain += " \ |
| 350 | ${datadir}/pipewire/filter-chain/* \ |
| 351 | " |
| 352 | |
| 353 | FILES:${PN}-alsa-card-profile = " \ |
| 354 | ${datadir}/alsa-card-profile/* \ |
| 355 | ${nonarch_base_libdir}/udev/rules.d/90-pipewire-alsa.rules \ |
| 356 | " |
| 357 | |
| 358 | # V4L2 interface emulator for sending/receiving data between PipeWire and V4L2 applications. |
| 359 | FILES:${PN}-v4l2 += " \ |
| 360 | ${bindir}/pw-v4l2 \ |
| 361 | ${libdir}/${PW_MODULE_SUBDIR}/v4l2/libpw-v4l2.so \ |
| 362 | " |
| 363 | |
| 364 | FILES:gstreamer1.0-pipewire = " \ |
| 365 | ${libdir}/gstreamer-1.0/* \ |
| 366 | " |
| 367 | |
| 368 | BBCLASSEXTEND = "native nativesdk" |