Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Parallelism library for C++ - runtime files \ |
| 2 | TBB is a library that helps you leverage multi-core processor \ |
| 3 | performance without having to be a threading expert. It represents a \ |
| 4 | higher-level, task-based parallelism that abstracts platform details \ |
| 5 | and threading mechanism for performance and scalability." |
| 6 | HOMEPAGE = "https://software.intel.com/en-us/tbb" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 9 | BRANCH = "tbb_2020" |
| 10 | SRCREV = "60b7d0a78f8910976678ba63a19fdaee22c0ef65" |
| 11 | SRC_URI = "git://github.com/oneapi-src/oneTBB.git;protocol=https;branch=${BRANCH} \ |
| 12 | file://cross-compile.patch \ |
| 13 | file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \ |
| 14 | file://GLIBC-PREREQ-is-not-defined-on-musl.patch \ |
| 15 | file://tbb.pc \ |
| 16 | " |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
| 19 | PE = "1" |
| 20 | |
| 21 | COMPILER ?= "gcc" |
| 22 | COMPILER_toolchain-clang = "clang" |
| 23 | |
| 24 | do_compile() { |
| 25 | oe_runmake compiler=${COMPILER} arch=${HOST_ARCH} |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}${includedir} ${D}${libdir} |
| 30 | rm ${S}/include/tbb/index.html -f |
| 31 | cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir} |
| 32 | for f in ${B}/build/linux_*_release/lib*.so* |
| 33 | do |
| 34 | install -Dm 0755 $f ${D}${libdir}/ |
| 35 | done |
| 36 | install -Dm 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig/tbb.pc |
| 37 | } |
| 38 | |
| 39 | # fails with thumb enabled: |
| 40 | # | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp |
| 41 | # | {standard input}: Assembler messages: |
| 42 | # | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]' |
| 43 | # ... |
| 44 | # | make[1]: *** [concurrent_queue.o] Error 1 |
| 45 | ARM_INSTRUCTION_SET = "arm" |