Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Tornado is an open source version of the scalable, non-blocking web server and tools that power FriendFeed." |
| 2 | DESCRIPTION = "Tornado is a Python web framework and asynchronous networking library, originally developed at FriendFeed. \ |
| 3 | By using non-blocking network I/O, Tornado can scale to tens of thousands of open connections, making it ideal for long \ |
| 4 | polling, WebSockets, and other applications that require a long-lived connection to each user." |
| 5 | HOMEPAGE = "http://www.tornadoweb.org/en/stable/" |
| 6 | LICENSE = "Apache-2.0" |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 8 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 9 | SRC_URI[md5sum] = "cf39425f3d7eba9a54287f3e795a2f23" |
| 10 | SRC_URI[sha256sum] = "0fe2d45ba43b00a41cd73f8be321a44936dc1aba233dee979f17a042b83eb6dc" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | # Requires _compression which is currently located in misc |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-numbers ${PYTHON_PN}-email \ |
| 16 | ${PYTHON_PN}-pkgutil ${PYTHON_PN}-html ${PYTHON_PN}-json ${PYTHON_PN}-certifi ${PYTHON_PN}-threading \ |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 17 | ${PYTHON_PN}-ctypes ${PYTHON_PN}-misc" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | |
| 19 | RDEPENDS_${PN}-test += "${PN} ${PYTHON_PN}-unittest" |
| 20 | |
| 21 | PACKAGES =+ "\ |
| 22 | ${PN}-test \ |
| 23 | " |
| 24 | |
| 25 | FILES_${PN}-test = " \ |
| 26 | ${libdir}/${PYTHON_DIR}/site-packages/*/test \ |
| 27 | ${libdir}/${PYTHON_DIR}/site-packages/*/testing.py* \ |
| 28 | " |