Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Filesystem and hardware benchmark and stress tool" |
| 2 | DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \ |
| 3 | stress/hardware verification. It has support for a number of I/O engines, \ |
| 4 | I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \ |
| 5 | and much more. It can work on block devices as well as files. fio accepts \ |
| 6 | job descriptions in a simple-to-understand text format. Several example job \ |
| 7 | files are included. fio displays all sorts of I/O performance information." |
| 8 | HOMEPAGE = "http://freecode.com/projects/fio" |
| 9 | SECTION = "console/tests" |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
| 12 | |
| 13 | DEPENDS = "libaio zlib" |
| 14 | |
| 15 | PACKAGECONFIG_NUMA = "numa" |
| 16 | # ARM does not currently support NUMA |
| 17 | PACKAGECONFIG_NUMA_arm = "" |
| 18 | |
| 19 | PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}" |
| 20 | PACKAGECONFIG[numa] = ",--disable-numa,numactl" |
| 21 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 22 | # rev for v2.9 |
| 23 | SRCREV = "fe8d0f4c54f0c308c9a02a4e3c2f5084e8bf5461" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | SRC_URI = "git://git.kernel.dk/fio.git" |
| 25 | |
| 26 | S = "${WORKDIR}/git" |
| 27 | |
| 28 | # avoids build breaks when using no-static-libs.inc |
| 29 | DISABLE_STATIC = "" |
| 30 | |
| 31 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'" |
| 32 | |
| 33 | do_configure() { |
| 34 | ./configure ${EXTRA_OECONF} |
| 35 | } |
| 36 | |
| 37 | do_install() { |
| 38 | oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir} |
| 39 | install -d ${D}/${docdir}/${PN} |
| 40 | cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/ |
| 41 | } |