Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "udisks provides dbus interfaces for disks and storage devices" |
| 2 | LICENSE = "GPLv2+ & LGPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=dd79f6dbbffdbc8e86b086a8f0c0ef43" |
| 4 | |
| 5 | DEPENDS = " \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 6 | glib-2.0-native \ |
| 7 | libxslt-native \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | acl \ |
| 9 | libatasmart \ |
| 10 | polkit \ |
| 11 | libgudev \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | glib-2.0 \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 13 | dbus-glib \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | libblockdev \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 15 | " |
| 16 | DEPENDS += "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" |
| 17 | |
| 18 | RDEPENDS_${PN} = "acl" |
| 19 | |
| 20 | SRC_URI = " \ |
| 21 | git://github.com/storaged-project/udisks.git;branch=master \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | " |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 23 | PV = "2.9.1" |
| 24 | SRCREV = "95444ab6bf2b8d8c205b540dded4029fcb15f91b" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | CVE_PRODUCT = "udisks" |
| 28 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 29 | inherit autotools-brokensep systemd gtk-doc gobject-introspection gettext features_check |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 30 | |
| 31 | REQUIRED_DISTRO_FEATURES = "polkit" |
| 32 | |
| 33 | EXTRA_OECONF = "--disable-man --disable-gtk-doc" |
| 34 | |
| 35 | do_configure_prepend() { |
| 36 | # | configure.ac:656: error: required file 'build-aux/config.rpath' not found |
| 37 | mkdir -p ${S}/build-aux |
| 38 | touch ${S}/build-aux/config.rpath |
| 39 | } |
| 40 | |
| 41 | FILES_${PN} += " \ |
| 42 | ${datadir}/dbus-1/ \ |
| 43 | ${datadir}/polkit-1 \ |
| 44 | ${datadir}/bash-completion \ |
| 45 | ${libdir}/polkit-1/extensions/*.so \ |
| 46 | ${nonarch_base_libdir}/udev/* \ |
| 47 | ${exec_prefix}${nonarch_base_libdir}/udisks2/* \ |
| 48 | ${systemd_system_unitdir} \ |
| 49 | " |
| 50 | |
| 51 | PACKAGES =+ "${PN}-libs" |
| 52 | FILES_${PN}-libs = "${libdir}/lib*${SOLIBS}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 53 | FILES_${PN} += "${nonarch_libdir}/tmpfiles.d" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 54 | |
| 55 | SYSTEMD_SERVICE_${PN} = "${BPN}.service" |
| 56 | SYSTEMD_AUTO_ENABLE = "disable" |