blob: 13cab430089860335c77c95e22db58abd885632e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
Andrew Geisslerd688a012020-09-18 13:36:00 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=ea2dc3f5611e69058503d4b940049d03"
Brad Bishop19323692019-04-05 15:28:33 -04007
Andrew Geisslerd688a012020-09-18 13:36:00 -05008SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=7.2.x \
Brad Bishop19323692019-04-05 15:28:33 -04009 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
11"
Andrew Geisslerd688a012020-09-18 13:36:00 -050012SRCREV ?= "2bd74943fb9f320def6c066e732b701d1c15f677"
Brad Bishop19323692019-04-05 15:28:33 -040013
14
15inherit setuptools3
16
17DEPENDS += " \
18 zlib \
19 jpeg \
20 tiff \
21 freetype \
22 lcms \
23 openjpeg \
24"
25
Brad Bishop26bdd442019-08-16 17:08:17 -040026RDEPENDS_${PN} += " \
27 ${PYTHON_PN}-misc \
28 ${PYTHON_PN}-logging \
29 ${PYTHON_PN}-numbers \
30"
31
Brad Bishopc342db32019-05-15 21:57:59 -040032CVE_PRODUCT = "pillow"
33
Brad Bishop19323692019-04-05 15:28:33 -040034S = "${WORKDIR}/git"
35
Brad Bishop26bdd442019-08-16 17:08:17 -040036RPROVIDES_${PN} += "python3-imaging"
37
Brad Bishop19323692019-04-05 15:28:33 -040038BBCLASSEXTEND = "native"