Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ea2dc3f5611e69058503d4b940049d03" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=7.2.x \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
| 11 | " |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 12 | SRCREV ?= "2bd74943fb9f320def6c066e732b701d1c15f677" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | |
| 14 | |
| 15 | inherit setuptools3 |
| 16 | |
| 17 | DEPENDS += " \ |
| 18 | zlib \ |
| 19 | jpeg \ |
| 20 | tiff \ |
| 21 | freetype \ |
| 22 | lcms \ |
| 23 | openjpeg \ |
| 24 | " |
| 25 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 26 | RDEPENDS_${PN} += " \ |
| 27 | ${PYTHON_PN}-misc \ |
| 28 | ${PYTHON_PN}-logging \ |
| 29 | ${PYTHON_PN}-numbers \ |
| 30 | " |
| 31 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | CVE_PRODUCT = "pillow" |
| 33 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 34 | S = "${WORKDIR}/git" |
| 35 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 36 | RPROVIDES_${PN} += "python3-imaging" |
| 37 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 38 | BBCLASSEXTEND = "native" |